Fix for game randomly crashing - tested for 3 days and it works

OK so I was having the issue where for no reason at all the game would just crash. Anywhere in the game at anytime. It was totally random. All my temps were in the 70s on high settings.

HERE is what I did and it worked…I didnt think it would but it did.

When these developers make these games they use a specific platform and toolset and it seems like the Microsoft Visual C++ distributable 2017 is what this game was optimized for.

I hit the windows button and selected: Settings > Apps > Apps & Features then scroll down and see if you have Microsoft Visual C++ distributable 2017 (can be called 2015-2019 sometimes)

If you dont see this in your app list then that it the problem.

GO here and download the x64 if you are running 64 bit windows and x84 if you are running 32 bit windows — > Latest supported Visual C++ Redistributable downloads | Microsoft Docs

I hope this helps you, it made my day, it has been working for me for 2 days now. I wanted to test it before I made this post.

You do NOT have to remove older versions of the C++ and you DO need to RESTART after it has downloaded and you go back and make sure it is in your app list.

ALSO if you DO have iMicrosoft Visual C++ distributable 2017 (or 2015-2019) then either repair it or delete it and redownload the latest version on MS website.

Good luck!

1 Like

I just tried that and id did not fix my freezing game bug sadly (game froze after 15 minutes) but glad it worked for you.

does it actually crash or just freeze? Is your temps normal when it freezes? What is your setup?

It just randomly freezes (game sound keeps going) system is running stable, nothing is hot cpu is on like 30 % gpu load goes back to 0 as if there was no game running.
Played without any issues on the release day for 10+ hrs and also in the open beta for 20+ hrs… this issue started on day 2 out of nothing.

cpu: ryzen 9 3900x gpu: rx6900xt ram 32 gb 3600mhz.

A lot of people reported the same issue.

1 Like

I didnt have quite the same, my screen would freeze, go black, no sound and then fatal error

I did this fix and all is good now and settings back up to max settings from just High. I’m i9-11900 K 2080 TI, 64 GB RAM.

Good luck I hope you can get it squared up!

It’s the same problem I have: Game Freezes - AZCore: Error code -2005270523

Edit: I suspect it has something to do with the GPU.

yeah maybe an AMD thing? I am not sure, the MS C++ redistributable fixed my issue. 3 days now

did your issue get resolved by doing this? @AlmaDeCenizas

I’ve had the same issues without any resolve. Currently have a ticket submitted as of yesterday with the technical team.
Crashing/black screening - only fixes by restarting pc and re-queueing

Did you download each one from the sections? Or is there a specific one on that page to download?
Either way I did them all and repaired my 2015-2019 that is already showing.
I’ll let you know if it helps.

Unfortunatly it does not fix it for me:

I did everything I could… I’m done with this crash error… :sweat:

exactly same circunstances for me, after the 159MB update the game started crashing randomly… im soooooo mad

Same here. After the update I seem to be crashing way more. Quite literally unplayable at this point between queue times and seemingly guaranteed crashes.

Might request a refund if I don’t get any good answers from the technical team.

1 Like

yeah all you needed to do was replace the 2015-2019. I am on day 3 and still no crashes even after update. There are probably multiple crash issues, but this one fixed mine and a few others I have talked to.

Are you having to lower your memory or clock speeds at all with afterburner or just running the game normally?

I deleted all the AGS folders in% appdata% and I was able to play for a couple of hours without problems, but as soon as I had to do alt + tab, it froze again, after that the freezes are constant again. So I don’t know if it was a coincidence or there is something else behind all this.

I put my core clock and memory clock speeds back to normal and the game crashed within 30 seconds.
I was able to play the entire day yesterday with the lowered clocks.
In queue now to try it again with lowered clocks. If this doesn’t work I’m out of options.

Here are the steps I’ve taken to be able to play basically 2 whole days in a row.
Currently using a 1080

  1. Re-download C++ Redistributable 2015-2019
  2. Open MSI Afterburner and change the Core Clock slider to -400
  3. Change the Memory Clock slider right under that to -502
  4. Manually set your GPU fan speeds higher on the right side (I chose 85%)
  5. Limit game FPS to 60
  6. Probably lower some settings to lower GPU temps (optional)
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.