Freeze after rollback

It’s 100% the servers being done over by whatever they said they are doing to “restore” the trading post etc…

Time to take a break I guess… every time I’ve wanted to log in the past 3 days it’s either maintenance or bugs or downtime due to this and that… becoming a bit of a joke tbh…

we have already done that

Jammington is it still working?

you mean not working? yeah I still cant play, waiting for Arkness’ answer

I get lag detected when transferring items from storage then it crashes

Ok right now im playing fine.
I ll share u what i did, but not enought time gone so dunno if it’s a fix or no.

I followed this guy:

"- Close the game and Steam

  • Go to the New World’s Installation directory
  • Right click on “NewWroldLauncher.exe” as admin (i have gone on properties → run as admin)
  • While game starts, should appear a message asking to launch Steam.
    -Click ok and close the game
    -Launch Steam and launch the game normally."

Then an error occured while in new world 1st ingame screen: image

Then i opened the game directory and deleted thhe “steam_appid.txt” file and Unchecked “run as admin” (in properties).
launch game.

Let me know.

1 Like

I tried and I didnt see your error, and still waiting my character to appear… I will re do some steps

I followed the steps and got the funny result

  1. When I enter the world I was instantly killed in the Winsward
  2. The game frizzes for 5 mins
  3. Got the message

did u get the error?

where is steam_appid.txt file

not working for me :frowning:

Edit: wait finally got error message

it apperead after launching the game as admin for me

dunno if someone understand german here, but a game supporter wrote on this trade. Cant translate it, but if someone can could help others…

BTW Im still fine

Same problem.

Kerguelen.
@Shivvies

No issues before.

After I delete steam_appid and launch game it still pop up same error image
over and over

He say he has the same problem nothing more. I translated in google. Btw I still have that problem. you r lucky Arkness:)

try using and vpn the character loading time vanished i am now 5 min ingame till now no freeze

im german and they discussing the same Issue. they tell to have a look at Fps deactivate v sync etc… i think they are far away from a solution

im going to reinstall steam and game

try using a vpn before you reinstall maybe it helps