hello after February Update im play game i go one MUTATOR EXPEDITION and i dont have problem but after i go one more MUTATOR EXPEDITION and in EXPEDITION my game completely frozen and im disconnect form server after 3 or 4 time try again And encounter with frozen screen I was disappointed and im close game have i can fix this.
im try verify files and GeForce driver update and restart my computer but it did not work.

Hi @mcchill welcome to our community :man_mage:

I’m so sorry that your game is stuck in the mutator expedition and crashes, we don’t want this ruining your experience playing new world.

The next troubleshooting step we can truy is to verify your game files:

  1. Press Windows + R, type “firewall.cpl” into the Run window, and then press Enter.

  2. Click Allow an app or feature through Windows Firewall and then click Change settings.

  3. Look for the game in the list of allowed apps and features. If it’s present, make sure it’s checked, and that both the Private and Public columns have a check mark. If the game is missing from the list, you must add it.

  4. Click Allow another app…, locate and select NewWorldLauncher.exe, and then click Add.

  5. Once you’ve done that, make sure that New World has check marks under both the Private and Public columns.

Updating your firewall software may help resolve connectivity issues. For instructions on how to update third party firewall software, we recommend checking the support pages provided by your firewall software publisher. If possible, you should also add an exception within your firewall software.

If you’re still having trouble, the next step is to disable or uninstall your firewall temporarily. We do not recommend leaving your firewall disabled long term. It should be enabled or reinstalled as soon as you’ve confirmed that it’s not causing your issues.

If this doesn’t work then please contact us trough the following link:

Have a great day! :dragon_face:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.