Furniture Stuck in Invnentory

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: PC Steel21
  • What server/world did you experience your issue on: Folkvangr
  • Describe the issue you are experiencing: My furniture is stuck in my inventory and I cannot drop it.
  • Is this a bug or an exploit: bug
  • (if a bug) How did the issue effect your gameplay: I cannot fast travel without paying extra azoth, nor can i carry a max inventory of material
  • (if a bug) Were you able to recover from the issue: no
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced: when this happened, i was dragging and dropping items from my inventory to my storage when i accidentally pressed “E” to transfer everything from my storage to my inventory. When i tried to move it back or drop it from my inventory it will not let me. It says “invalid transaction.”
1 Like

It’s been disabled due to the last round of duping just don’t overload yourself with furniture or house fittings

I have the same issue except its furniture im getting from drops so i cant even control that and they cannot be salvaged like the Devs claim they can be. So screw us i guess.

yeah dont pla too much or your teleports will be super expesnive soon HAHAHHAa those guys dont think about what they are doing. Just quick weak fixes which arent even quick :smiley:

Thanks for making this post so i dont have to. I have so much furniture stuck in my inventory… fml

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.