(GAME BREAKING) December patch now wont let me start my game

Every time I start my game it opens and just sits at that first new world screen. I have verified files three times, restarted my PC, and reinstalled the game none of this has worked. When I open task manager new world has two processes open one of which is the game crasher uploader.


bump

Hello @FuryFist13F!

I’m sorry that New World is not actually opening and just getting stuck.

Can you please try this troubleshoot.

1- Win key + R
2- Type %appdata%
3- Go to AppData > Roaming > AGS > New World
4- Delete the Savedata folder and the user_preload_settings.cfg file.
5- Reboot the PC and you’ll see that the files deleted would be recreated.

Also, make sure all drivers are updated as well as Windows. You can also try to run a System File Check: Use the System File Checker tool to repair missing or corrupted system files. This is just in case that New World is still not working maybe you can find the problem.

This should fix the issue. However if the problem persists don’t hesitate to contact back to find a fix for your particular issue.

Have a great day :crossed_swords: :shield:!

1 Like

I am updating drivers now to see if that will fix the issues if not will use the trouble shooting process suggested.

Game is working again! Thank you so much!

1 Like

Issue still not fixed even after going through all of these steps

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.