Game crash to Windows

Ok,
Here we go again.

I tried to play NW at laptop at free weekend, but today i install it on my gaming PC

And… it crashes to windows. Just like i complained here: Game freeze and quit to windows (i9 9900K @RTX2080Ti, @64GB RAM)

Nothing chnge with my spec.
TX 2080 Ti, 64GB ram, win 11, intel i9-9900K, lates nvidia drivers (512,15)

(Detailed PC spec in teh linked topic)

I tried to reinstall NW, checked steam files intergity, run as admin, updated nvidia drivers, started windows at safe mode.
Nothing helped.

Help.

I want to give the game chance, but it looks like my hardware is pretecting me from that :wink:

Hello jotes1982,

I’m so sorry the issue still persists launching New World. Thank you so much for sharing the troubleshooting you have done so far.

The next troubleshooting we need to verify is the AGS Files that are linked within New World:

  1. Windows + R type in %APPDATA%
  2. Go to Local and Roaming (Both files will include an AGS file) and open them.
  3. Rename the AGS sub-folder ‘‘New World’’ to something different like ‘’_New World"
  4. This will refresh the cache files within New World and remove the error launching the game.

A previous Forum I was working with a another player, we found the only solution for this launching error was this troubleshooting, you can check this Forum with this link: Main Menu buttons don’t work + character/Worlds wont load .

Please let us know as soon as possible if after these troubleshooting the problem persist.

Thanks for all your feedback and specially your patience. :man_mage: :small_blue_diamond:

Ok, thanks.

I deleted files you mentioned about and it look like it works.
I’ve played for over 2 hours and nothing freezed.

Thanks again.

I’m really glad the troubleshooting worked for you jotes1982,

It was a pleasure helping you and I wish you safe travels in Aeternum. :world_map:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.