Game crashes every 2-3 minutes after today's patch

Thanks for suggestion @Neyriks, but this made no difference in my case whatsoever :frowning:


To keep it up

Hello guys,

After some research it seems this error can be caused by a problem with the HDD or SDD in which the game is installed. If you have several hard drives, please try to install the game in a different one to check if this helps.

You can also try to run Check Disk Utility on Windows, to do this:

  1. Go to This PC
  2. Right click on your drive
  3. Select properties
  4. Go to “Tools” tab
  5. Under Error checking, select “Check”

Another solution could be performing a clean boot in Windows, check the steps here: How to perform a clean boot in Windows

Let me know if some of this helps :slight_smile:

I’m also having this issue, as of approx. three days ago. Played for 216 hours, almost level 60, no issues whatsoever - then suddenly and without any change at my end, I’m getting crashes within two minutes of opening the game, every time I try to play.

No error message. The game freezes and then closes to desktop. It’s now completely unplayable.

I’ve tried everything here and none of it has helped.

I’ve had a fresh install of Windows in the last month. I shouldn’t have to perform a clean boot just to get New World to run. I paid good money for this game and it should work.

I’m still having the same issues!!!

I’ll tell you that it changes from patch to patch. Last patch was fine, game crashed once every day or 2. But todays patch has broke it again and it crashes randomly. Sometimes 5 min and some times 45. Support team is terrible, as multiple tickets raised and no help received !!!
I’v provided you with required files and logs. What else can I do???
Can you please do something about it!!!

What makes you think that this issue is High atency related?
I have no indication of that.

Others have the same issue, seems to be server side

Well, this would be extremely weird, as my daughter is absolutely fine and is using the same bradband I do.

The most common solution is to clear the $appdata% associated with the New World client:

Invoke the Run box - type %appdata% and click OK.
Go to AGS > New World and delete the following:
–>The savedata folder
–>The user_preload_settings file

Restart computer and check for crashes.

Additionally, if you tried chkdsk /F and it also failed to resolve the issue for you, then you may need to elevate admin priveledges associated with your login account. Error 299 usually occurs when there is not sufficient access to read/write/modify files that are written to the destination drive. If you are hesitant to assign Admin privilege’s to your user account, you can install Process Monitor and set a query result to Access Denied to see which file or process is causing error 299. When you find the New World process that is being restricted, you can take ownership of that folder under Advanced Security Settings to ensure that the client is able to modify the necessary files under your account.

Thanks for the reply, but I’ve already tried both of those suggestions - alas, to no avail.

I also already have admin privileges.

What’s “error 299”? I don’t see an error message before or after my game crashes. The game freezes and then closes to desktop.

Thank suggesting that, but if you read my very firs post you will know that I’ve tried everything :frowning:

hello, having the same issues here. game keep freezing since last patch, its literally unplayable, i tried everything and still have this issue. I dont know if is a connection problem but i never had problems before

Am i the only one who’s having this issues in specific time of the day?

Ok, enough is enough!

I’m sick and tired of this shtshow!!!
Is anyone ging to do ANYTHIG???

Because of client crashes I’m getting penalised for leaving the outpost rush!

Get this game sorted!!!
How many tickets does it take???
I will spin a proper sht storm on social media. At this point I had enough!!!

1 Like

And this is soemthing new !!!


FFS, honestly…???

1 Like

Hello @brzydle.

Thank you for reaching out about this issue and welcome to the forums.

Please let me know if you are still having this issue.

Feel free to tag me if you need to.

Safe travels! :mage: :snowflake:

Hi @Bmango,

The game ios working just fine since the December update, thanks for asking.

As I got your attention now, you can have a look at this post please:


ya bro, its pissing me off now too. I have come to NW defense against haters for months, but now I can’t defend this crap. Crash in OPR = 1 hour ban for quitter penalty. Crash in Dungeon = group kicks you. Crash in Portal/Elite Chest runs = by time lucky enough to log back in, you are left behind. Crash fighting any mob = when you can finally log back in, you have died and are sent back to nearest town.

To sum it up: Its now 2022 and we have been crying out for help on these issues all over the internet for months and AGS has no solutions. I have literally spent more hours each day troubleshooting the game than actually able to play. The crashing gets more consistent and worse as each patch releases and now it’s gotten to the point with my particular system that the game is unplayable. If I’m lucky I am able to even get past the Amazon logo screen and to the character screen. If i’m super lucky, I can login the game for a few minutes and then it’ll crash, system will reboot itself and then I can’t get back into the game, even after multiple attempts.

@Bmango Happy New Year!! But why is this not being addressed when so many of us are begging for help and so many others have given up and just quit. I truly want to stay with the game, but it has become unplayable and I want to make it work. I’ve open numerous tickets and customer support just gives me cookie cutter responses that don’t even work.

What are we to do???

Keep having the same issue since the void patch. Especially during 21:00 pm to 23:00 pm. The game keeps freezing and crashing. I tried all the trouble shooting and didnt work. An amazon employee from live chat told me that this was gonna be fixed on the updtae of 30th december but obviously didnt work.

1 Like