Game crashing since I updated windows 10


I updated to the winter update and played fine today, no issues. I had a windows 10 update and since then whenever I open the game it just freezes on the ‘new world’ screen. If I close the game down it is still running on my task manager.

Never had this issue before so unsure what has happened.


Hello @crumpetking17.

I am sorry for the issue. Please try the below steps and check if the issue is resolved.

Fix 1: Verify the integrity of game files.

  1. Open your Steam client and go to LIBRARY . Right click New World and select Properties .
  2. In the left pane, select LOCAL FILES. Then click Verify integrity of game files.
  3. Allow the checking to complete. Then you can start New World and see if it crashes again.

Fix 2: Update your graphics driver

Prior to the release date, both NVIDIA and AMD have published the New World compatible GPU driver.

You can update your graphics driver manually, by visiting the manufacturer’s website (NVIDIA /AMD ), finding the latest correct installer and installing step-by-step. But if you don’t have the time or patience to install manually, you can do that automatically with Driver Easy .

  1. Download and install Driver Easy.
  2. Run Driver Easy and click the Scan Now button. Driver Easy will then scan your computer and detect any problem drivers.

Fix 3: Increase your virtual memory

  1. On your keyboard, press the Windows logo key and type advanced system settings . Click View advanced system settings .
  2. Under the Performance section, click Settings… .
  3. In the pop-up window, navigate to the Advanced tab. Under the Virtual memory section, click Change.
  4. Deselect the Automatically manage paging file size for all drives checkbox. Then select Customize size .
  5. Enter Initial size and Maximum size according to the physical memory of your computer. Microsoft recommends that virtual memory should be 1.5 to 3 times the size of physical memory. In my case, the physical memory (actual RAM) of my computer is 8 GB, so the Initial size for me here is 8 x 1024 x 1.5 = 12288 MB , and the Maximum size should be 8 x 1024 x 3 = 24576 MB . Once you’ve entered your size of virtual memory, click Set , then click OK to save the changes.
  6. Restart your computer and check if New World crashes again.

Fix 4: Delete specific game files

You should back up the files before deleting in case things go wrong.

  1. On your keyboard, press Win+R (the Windows logo key and the R key) to invoke the Run box. Type or paste %appdata% and click OK.
  2. Go to AGS > New World and delete the following:
    The savedata folder
    The user_preload_settings file
  3. Now you can restart New World and see if the game crashes again.

I hope this helps!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.