Game Freeze ..... Again

Three times this morning between 5:30 and 7:30AM EST on Castle of Steel, my character MichaelGaribaldi has experienced game freeze that required closing the window from the window task bar (2 photos attached because I didn’t think 3 was necessary)



Closing the game, however, did not stop Steam from continuing to run which required a separate stop order in order to close Steam.


Each time the game froze, I successfully validated Steam files before opening the game again. The first time I reopened the game, it would play but I could not remove the Windows task bar from the bottom of the screen without closing the game (again) and re-opening. I’ve checked my internet connections for reliability/speed and made sure there was no excessive or spurious items in my CPU memory cache. Not a playable experience if this keeps up.

Having the same issue. Mainly after teleporting for me tho

9:15 AM Maramma server with character Susan lvanova…game freeze, close with Windows task bar, close game still running on Steam. Did not take picture of frozen game because at this point it does not matter. Time to see what sunlight is like.

Yeah, servers are running like crap… I was getting a lagspike every 3 minutes… Holy shit buy me new pc ty

1 Like

So…I found a potential solution on another game freezes thread and tried renaming the New World files on my PC and it worked…for a couple of hours, then


Same old server freeze that has to be forcibly shut down then shut down a second time on Steam.

Hello @Susan_Ivanova, @Infecit, and @GlowSticks,

Thank you all for your input. I am sorry to hear you seem to be having sporadic crashes or disconnections.

Please try the following steps in order to troubleshoot this:

1- Please verify the integrity of game with the Steam integrity check
How To run a Steam Integrity Check
2- Close other applications that may be taking up your bandwidth.
3- Switch to a wired connection.
4- Restart your router and modem.
5- Troubleshoot your firewall.
-Press Windows + R, type “firewall.cpl” into the Run window, and then press Enter.
-Click Allow an app or feature through Windows Firewall and then click Change settings.
-Look for the game in the list of allowed apps and features. If it’s present, make sure it’s checked, and that both the Private and Public columns have a check mark. If the app is missing from the list, you need to add it.
*Click Allow another app…, locate and select the app, then click Add.
*Once you’ve done that, you need to ensure that the app is checked, and that it has check marks under both the Private and Public columns.
6- Test your connection for packet loss or buffering. To test, go here and click the big Start Test button to start the test. Once the test is complete, the results are displayed.
7- Ensure all your Windows and driver updates up to date.
8- Verify you are not using VPN or proxy services. (Note the use of VPN is not permitted when connecting to our servers).

If the issue persists after this, the scenario will require our tech team to look into your logs and follow up directly with other possibly sensitive account information that is best not posted on the forums so it would be best if you could please create a web ticket by going to Contact Us | Amazon Games.

I hope this helps and if not, do not hesitate reaching out to live support.

See you in Aeternum! :wolf:

Yeah been having the same issue since the event update, today its been happening more frequently, pretty much unplayable right now.

1 Like

Yeah…well I’ve tried a second “solution” by actually deleting the data from the roaming file which again only provided temporary relief. There are no impediments from an Internet perspective, no lost packets, no firewall impediments…just intermitant game play. I’m now trying the “Contact Us Amazon Games” which links to Amazon Help that does not provide a pre-select for AGS so we are dealing with “Something Else”. Color me very unimpressed.

1 Like

Four Amazon Customer Service representatives later, I’ve been given a list of tasks designed to flush and reset ipconfig. I have a wild theory. This PC has been running this game since Alpha as well as everything in my Steam library for almost a year; that is up until the last update of New World. The first temporary solution forced the game to create new AGS files. The second temporary solution was to delete the content of the roaming AGS file. What if…the latest update unintentionally shifted certain certain parameters causing these AGS files to cause a game freeze after X amount of game time? What if these “side quests” are just a delaying tactic to determine what else went FUBAR in the last update and provide a hotfix? Brings me back to the glory days of WoW when updates would crash everybody and Blizzard would blame users PCs for days until they hotfixed the game…

3 Likes

I was able to play the game last evening for about two hours without crashing after the scripted ipconfig exercise given to me (but I also deleted the contents of the roaming AGS New World savedata file first). Here is a glimpse of the kind of performance my pokey little computer gives me


I will log into the game shortly (without deleting the contents of the aforementioned AGS file) and see just how long it takes the game to freeze. I will think pure thoughts and hope that the scripted ipconfig exercise I was given yesterday did the trick. By the way, I loved the follow up e-mail from Amazon Support regarding my latest Lost Ark game inquiry…can’t even click on the right scripted e-mail to send…smfh

1 Like

Okay I contacted live support and their fix worked for me, steps:

-From the start menu type cmd
-Right click on Command Prompt and select Run as administrator
-Type ipconfig /flushdns and press enter
-Type ipconfig /registerdns press enter
-Type ipconfig /release
-Type ipconfig /renew
-Type netsh winsock reset
-Restart your compter

I hope it works for everyone as well.

1 Like

Since performing the ipconig routine given to me on attempt #3, I have run the game without event for 1 day. Will continue to think happy and pure thoughts so that it may continue.

Just when I thought I was out of the woods on this one…earlier this evening, there was a large lag spike that disconnected a few people from the server.


I logged back in and “a few minutes later”…freeze that could only be closed by Windows Task Bar or Alt+f4 with a separate shutdown of Steam as it continues to run the game.

The odd thing is that at the time of freeze, all the telemetry for the connection is well within working tolerances. I was able to re-start the game and continue for an hour or so before logging for the evening. Let us see if tomorrow brings more pain or if this was a one-off.

1 Like

It is a new morning and guess what happened exactly when my character first appeared on the screen after logging in…freeze that Alt+F4 would remove and a separate shutdown of Steam because it thought the game was still running


So…I guess I’ll delete the data from the roaming AGS file (AGAIN) and wait for more sage advice like running the ipconfig routine (AGAIN) or some other witchcraft to remove the curse that is affecting only this cursed game.

1 Like

Same issue since the update. I have never had an issue before with any game or this game until this last update. I have done everything mentioned here plus…

1 Like

Happened again…only this time I popped Task Manager before hitting Alt+F4 to close and my computer shows the game still running and using a metric f-ton of memory.


Again the only way to shut the game down is to Alt+F4 or close using the Windows Task Bar. Again Steam still continues to run and play background sounds from the game until you manually stop the program. Are we having fun yet?

1 Like

@Susan_Ivanova I see you have Nvidia graphics…I do too. Long story short I use Gforce experience and it usually updates my drivers. My drivers haven’t updated since June and I couldn’t update them using Gforce experience. I went straight to the Nvidia drivers site and downloaded the July 28th updates and re downloaded the Gforce experience. Everything seems to be working fine now. Did a full WT no problems. Keeping my fingers crossed.

1 Like

About that…checking drivers is one of the first things I did. My 3060 is up to date.

Just to be sure, I double checked in Nvidia web site

@Susan_Ivanova my drivers update also showed June 28th but they update monthly meaning there was no July update which was weird. I was able to download the July update but then again I dont have a 3060, I’m just running a 1660. Shouldn’t they all update at the same time? I hope you figure this out. Good luck.

Hello @Susan_Ivanova and thank you all for your input on this.

I am sorry to hear the troubleshooting steps listed by myself as well as others has not cleared the issue for you. Please note the next step in my previous post states you would need to follow up with a ticket to support so do not hesitate making one and following up with it via Email for any other possible troubleshooting.

Best of lucks and see you in Aeternum! :wolf:

1 Like