Game is unplayable now due to rubberbanding / stuttering

That’s probably server/region detection in menu, you know that dropdown list. That doesn’t mean anything, everyone will have something similar in that log. You won’t see anything meaningful in game logs.

Ah, ok, thanks :+1:

anything here from the devs?

I am getting the exact same thing, rubber-banding, desync and just generally a laggy mess. My internet is fine as is my PC. 8700k and a RTX3090, i also play at a mix of low and high settings (high for textures and models) everything else low.

The game is pretty unplayable for me atm :confused:

The game became noticeably more laggy after the 1.0.5 patch. Most notably in OutPost Rush. Up until the servers went down before the update, the game ran near perfect for me and dare I say…I was having fun. Once logging into 1.0.5 there was the 250 STR bug that caused the stutter lag after skills and certain cc abilities. Whatever they did to Outpost rush caused a drastic increase in lag/de sync issues. Open world is still alright aside from the STR stutter bug.

My temps are always good, my FPS is always good and my MS/Latency is always good. So whatever they did with that patch needs to be addressed.

At the moment War/Outpost rush is pretty unplayable. Open world is not bad. I blame myself for having fun and getting my hopes up with 1.0.4….Got taken away as soon as I started enjoying the game and we got 1.0.5.

I would take the hatchet bug back if we could go back to how the game ran in 1.0.4.

Summary: 1.0.5 was a flaming disaster of a patch. Good news, 1.0.6 can’t possibly be as bad as this one……right….?

It seems every new patch more and more people are getting this issue, It’s like whatever is causing it is being reproduced in each patch or something.

Another thread made it sound like a fault with character data.
be interesting to test using another PC to see if the same issue occurs (or get someone without the issue to try on one of ours etc).
I do have the game installed on my laptop but it’s even more of a potato than my PC so I’ve only played it on there the once and that was with the ‘can’t interact with objects’ bug what was supposed to have been fixed.

I’ll get my cousin to try mine character later, he is on the same network and does not get any of these problems.

It will be this evening, but I will update you then. :+1:

Last night I spent an hour on it and I thought it was fixed I had almost no issues for half that time, but did get a few glitches.

Hello, I will share my experience with unplayable lag , even lagouts that disconnected me after about October 28th.

I have tried every setting within New World and nothing fixed the problem. I updated my GPU driver. Updated my drivers for my CPU, my motherboard, and my NIC. I allowed the correct ports to remain open on my router for New World. I allowed New World through my firewall. I made sure to restart my router fresh before any time I would play. Windows is up to date. NONE OF THESE THINGS WORKED.

Finally, I decided to throttle New World to a max of 5mbps bandwidth. Last night I was able to play for about 3 hours with little to no lag. Once, the game lagged out during the 3 hours, but I was able to rejoin from the main menu and it was fine again.


Experiencing really bad rubberbanding despite 10ms - 30ms latency. Playing on Med graphics settings.

1 Like

So my upload drops to abysmal levels when I play this game. Like anywhere from .4 to 2 when the input latency starts to spike. Once again does not happen when I play other games. Dunno what to do.

Yeah, I’m going to echo this concern as well. While playing other games, my speeds are 250-300 Mbps (down) and 10 Mbps (up). When I’m playing New World, my upload speed drops to 2.4 - 2.5 Mbps.

My networking equipment is Ubiquiti and the Unifi dashboard does not show anything out of the ordinary. It’s just crushing my upload speeds.

Since last night I’ve had barely had any issues, the only thing I did differently, was run Razer Cortex as far as I can remember.

Update* This past week I have had far fewer issues, but it does still sneak in sometimes.

The only things I’ve done was disable XMP in bios and run Razer Cortex.

I don’t know if any of those have improved it for certain, I would need to do some testing.

Anyway, it’s worth a try.:+1:

The only time I experience any kind of lag/rubberbanding is inside OutPost Rush. My FPS and MS never Drop/Spike when it happens either. I stay around 70-80MS and my FPS/Temps are always good (Even inside cities). NVIDIA drivers are up to date with the latest Game Ready Drivers, as well as every known driver on my computer is up to date. Tested internet connection and packet loss and my internet runs perfect and no issues on other games. It 100% started after 1.0.5 went live.

I had the same issue. Today I had less lag (like only 4 times in 4hours).

What happend was the following:

I changed some of my Chat-Notifications. I deactivated some and activated some as “highlighted”.
I changed everything back to “Feed” and today was less lag. This might help some people. And Dev’s should check out if there is a problem with the coding of the Chat.

I’ve tried absolutely every solution I could find on the internet. Still Stutters.

Game Build(1476313) 09 Nov 21 (16 56 29)

Video record

I just died in Outpost rush, cant spawn, just keep clicking on the button which was returning me back to select spawn, which was not even possible, reloged, went to queue, aftert that infinite loading for 15 mins. Top notch.

Hey folks,

We understand that this is an issue that is affecting all of you, and we want to gather more information.

In order to gather this information in the best way possible please post the following information this post [High Latency & Stuttering Issues]:

  • Describe what you were doing when it started to happen:
  • World ID:
  • Bandwidth settings:

Our Dev will gather this information and review what’s the issue is about.

1 Like