Game Lagging when I open my Storage Shed

  • What is your character name in New World: Ronan Navrin

  • What server/world did you experience your issue on: Valgrind

  • Describe the issue you are experiencing:

So I have a strange issue where every time I try and open my storage shed in town the game will lag really hard for about 5 minutes before having to reload the instance about 2 or 3 times before finally letting me move around again. Now this has only happened recently and I haven’t added anything to the inventory that hasn’t been or wasn’t there before. I don’t carry a massive amount of random things and tend to keep it as condensed as I can. I only make this bug report because this really hurts what time I do have for the game and my ability to play when I’m sitting there, doing nothing, waiting for the game to reload for about 15 minutes because I happened to just…open my storage. Rarely can I get into it and actually pull things from it or just put things into it.

Also a side note, Some of the workbenches do the same thing and more, particularly the outfitting bench as it will either lag me out of using it or my character will just constantly cease using the bench and stand up straight and face away from it on his own. I have to try about 10ish times to actually get to working on my armoring once more with repeatedly opening and closing the window just to activate the bench properly so that I may craft within it and not be booted the instant I try to craft.

As for attempts to solve this issue, I have tried removing what I could and reducing the amount of items in storage as much as possible, though I only get so far with that before being lagged out again. I have also set all my Graphics settings to low so if it is a graphics issue its not one I can solve on my own here. Even still, it doesn’t explain the hard lags with workbenches for me and doesn’t exactly help when I’m trying to use the outfitting station and my character just doesn’t do it. I make mention of the outfitting station because it is the most frequent offender of me having to open and close the workbench many times just to use it and hope I don’t lag the system. I don’t know why but my character refuses to go into the working animation and instead cancels and turns around many times before finally accepting the prompt to work.

  • Is this a bug or an exploit: Bug for sure

  • (if a bug) How did the issue effect your gameplay: Hinders my ability to actually play the game because I can’t do anything while ‘Lag Detected’ is displayed for a solid 10minutes and the game has to reload the instance to maybe work properly. Sometimes it reloads and works and other times it simply has to lag more and reload again…and again. Record time now is about 25minutes roughly and 4 reloads in a row before I was allowed to move again.

  • (if a bug) Were you able to recover from the issue: This issue only happens to me in Windsward and it only happens when I interact with a bench on occasion or most commonly with the Storage Shed. I can recover from it fine but I can’t get back my much lost time and desire to play when I’m stuck dealing with this issue. I do love this game and I want to love it more but this is one more problem upon many that just compounds the frustration.

  • (if a bug) Please include a screenshot or video of the issue that you have experienced: I would but there is only so much info you can get looking at a screen that says “Lag Detected” when I try to open storage.

  • What are the steps to reproduce the issue as you experienced: All I had to do was open a workbench or my Storage. It is very consistent and happens extremely frequently, at least to me.

Both my wife and myself having the exact same issues. Have tried:

  • Changing my DNS from CloudFlare to OpenDNS to Google and back to my ISP’s default.
  • Using two different VPS, in various cities (here in Ontario Canada) and across the border in NY state.
  • Restarting router, and all the normal stuff you would do first.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.