Game stutters on 2nd monitor

Hello and happy thanksgiving!

So I’ve bought a new monitor (MSI Optix G24C6) to connect to my laptop (MSI GE 75 Raider 9SF) however if I disable the laptop’s screen and choose “show only on 2” from windows options, game starts to shutter even while if I have 90 fps and feels like I have 5 fps. If I enable laptop’s screen everything is fine again. Both monitors are 144 hz and connected via a display cable that supports up to 240hz. The issue only occurs with New World. Tried disabling g-sync via nvidia control panel after reading it may cause the issue yet no luck. Been checking if it forces usage of intel hd graphics but it seems like game is running on my rtx 2070. I don’t know what else to do at this point and any help is appreciated.


Hello @Falwyn,

I’m sorry you are experiencing stutters on the monitor, please try these steps if you did them already and you are still having issues contact us through chat support Contact Us | Amazon Games to escalate issue.
Note: If you’re using a monitor and GPU setup that supports Nvidia’s G-SYNC or AMD’s FreeSync, we suggest using this functionality instead of turning V-Sync off entirely. While turning V-Sync off will result in the lowest input latency, it could also cause screen tearing. Screen tearing is a visual artifact that can occur when the video feed isn’t in sync with the display’s refresh rate.
For more information on this, refer to Reduce Input Lag in PC Games: Definitive Guide | DisplayLag.

Hope it helps, take care.

1 Like

Had to edit this after reading more. Looks like you’ll just have make sure that you manually enable G-Sync for the display in the graphic’s card’s control panel, and of course make sure FreeSync is enabled in the monitor’s settings as well. Try various other settings and maybe you can get it working correctly. And note your cable may not actually work as advertised based off my experience. And nvidia supports freesync via Display Port only.

This may be outdated a bit;

  • Right-click on the Windows desktop and select Nvidia Control Panel
  • Expand the Display section of the left-hand navigation pane and select Set up G-Sync
  • Check the “Enable G-Sync, G-Sync Compatible” box and select the Active Sync display you’d like to use if you have more than one monitor
  • Check the “Enable settings for the selected display model” box
  • Click “Apply” in the bottom-right

“If the above isn’t available, or isn’t working, you may need to go to Manage 3D Settings, click the Global tab, scroll down to Monitor Technology, select G-SYNC Compatible in the drop down, and then click Apply,”

Monitor freesync setting is under Gaming/scroll down to Freesync and enable.


And only Adaptive Sync displays certified as “G-Sync Compatible” are guaranteed to work well with Nvidia graphics cards. If you try manually activating G-Sync on other FreeSync monitors, “It may work, it may work partly, or it may not work at all,” Nvidia says.


Hello again, thanks for the assistance guys, apparently it was about g-sync and forcing the settings for 2nd monitor via enabling it up for both screens one by one solved the issue. Thanks for the help. Wish you have a great day!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.