GreatAxe Reap skill

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World:
  • What server/world did you experience your issue on:
  • Describe the issue you are experiencing:
  • Is this a bug or an exploit:
  • (if a bug) How did the issue effect your gameplay:
  • (if a bug) Were you able to recover from the issue:
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced:
    FrenchTickler
    Pyrallis
    The REAP skill in the Great Axe tree doesnt work and hasn’t worked in over a week. It’s doing no damage at all. How has this not been addressed quite embarassing? I’ve submitted feedback after feedback even have video footage. You released patch notes but no sign of this being addressed. It’s all over forum so there’s no way you can use the excuse we didnt know about it. A major part of the game a skill doing no damage should be fixed instantly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.