Heads or tails quest bugged

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Mordrig
  • What server/world did you experience your issue on: Oceana
  • Describe the issue you are experiencing: after completing quest heads or tails (Elite) in cutlass keys I received the ring reward but the quest reset and did not “complete”. Unable to complete toss a coin arc quest achievement. I tried deleting quest to restart but the quest has disappeared.
  • Is this a bug or an exploit: bug
  • (if a bug) How did the issue effect your game play: I cannot complete cutlass keys arc quest achievement Toss a coin.
  • (if a bug) Were you able to recover from the issue: No
  • (if a bug) Please include a screenshot or video of the issue that you have experienced: I cannot provide anything as I cannot restart the quest as it disappeared.
  • What are the steps to reproduce the issue as you experienced:
2 Likes

Same problem here

same problem here: Elyana Silvanae on Westernesse Theta > Nidavellir. The quest stated it failed after I turned it in to Trost. It is still in my journal and acting like I never did it at all.

Same problem :frowning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.