High cpu gpu problem!

The game consumes a lot of gpu. I play on the lowest settings, sometimes freezing and stuttering happens.

Shes runs a little hot but this has been like this for me since day one launch. I run at 99% of GPU, 47% CPU. I was told this is normal by a tech friend.

1 Like

I play with a 2070 super and a newer AMD CPU. The GFX is usually maxing which is good it’s being used to it’s fullest. I have about that same 47% CPU usage. Note that I do play on 2560 x 1440 on very high settings. The big thing you may not have considered that I’ve seen is the amount of memory usage. The game even when I had some issues earlier on and did drop down to 1920 x 1080 and low settings to test, is that the game is using 15.9 basically 16 gigs out of my 32 gigs of RAM. That’s a lot. This is a pretty demanding game but I have a feeling a lot more big open world games might be headed this way.

ryzen 9 5950x,asus KO 3060ti, 32 gigs trident 3600 , strix mobo, seasonic 850 platnium… this game for some really strange reason skyrockets gpu/cpu usages and temps when it shouldn’t , its so poorly optimized , this game actually reboots my router and puts my fans up to like 1800 -2k rpm where no other game i have affects my pc like this and are way more graphical demanding , like BF 2042 while streaming on the same pc while listening to music doesnt touch my pc like this game , alot of people quit cause of the performance issues, so im electing to stop playing it myself , expensive equipment to ruin .

@yusuf10

I have an RTX 2080 and another thread for hot temp. Getting upwards of 107c and averaging 106c since the latest patch. Never had such high temps when gaming.

I recommend you do what they told me to do which is make sure you validate game files in steam and post your DxDiag and game logs for their team to look into.

Here are the instructions they gave me.

Verify Files Integrity
In order to to that, go to your Steam Library and Right Click on the New World Title > Properties > Go to the Local Files Section > Then run the “Verify integrity of beta files” check. If the integrity is not OK, please reinstall the game and check if it solves the issue. If the integrity is OK, please proceed to the next step.

Additionally, you could try Capping the FPS to 60 in-game to see if it helps!

If the issue persists, please provide your DxDiag and your game log files.

Instructions for generating a DXdiag: Open and run DxDiag.exe 2 (Open and run DxDiag.exe)

Instructions for finding the in-game logs:

  1. Press Windows+R on the keyboard, type %appdata% and press enter.
  2. Open the most recent file from this folder: /AppData/local/AGS/LogBackups.
  3. Paste the contents of the file into your message.
  4. With this information, we’ll be able to investigate the issue further.
1 Like

oh mines not that high actually my pc fail safes at 85 degrees celcius , 107 degrees celcius would cook your pc
mine gets to 71

2.6 GHZ base frequency, Guess this is a laptop?(and since Igpu is active)

With that kind of cpu and an 1050Gtx this is completely normal for a game like this, even on low.

Though when you are this extremely limited on resources turning on “Low Latency Mode” in NVidia control panel will help out your frame times by alot.

2 Likes

yes asus fx503vd my laptop thanks

Not enough ram , lowest tier gpu from 6 years ago and mobile cpu
Cant expect to run 2021 AAA titles fine.

Hello @yusuf10

Thanks for the report. I’m really sorry about the problem you’re having.

Here are some steps to try to solve the issue. We know that you already had tried some and it can be repetitive, but many other players were able to fix it after doing the steps. Please try going step by step as follows.

  • Check for pending BIOS updates.
  • Verify that the drivers are correct and up to date: New World Compatible GPU Driver Update - Support
  • Run a file check: Steam Support :: Verify Integrity of Game Files
  • Check the EAC: Locate the game directory, and then select the “EasyAntiCheat” subfolder. Click EasyAntiCheat_Setup.exe to run the installer as an administrator, fix it if necessary.
    Note: The Steam Games installation directory will generally be in: C:\Program Files\ Steam (x86)\ SteamApps\ Common
  • Avoid using VPN, and you should remove other programs such as bots to mine or fish or to avoid being AFK. (if installed for any reason) Even overlays to get unofficial maps for the game.
  • Check out New World System Requirements - Support | Amazon Games it is very important that you are using Windows 10, because for 11, New World is not yet optimized.
  • You can lower the resolution to High in the settings.
  • If running Discord, run Discord As Administrator as well.
    After all steps above:
  • Shut down the computer completely. Turn it on, then run the Steam client as administrator, Discord as Administrator and try the game again.

Please note, if the computer is running with the minimum system requirements, it will give you some issues if you are playing with other programs opened. Make sure to check the RAM capacity and close any other program you are not using. * Try a clean boot of Windows: How to perform a clean boot in Windows . (This will disable all non-essential programs from starting and test if there’s any background programs causing a conflict with the game.)

Thank you.

I did everything you said but found the problem. There are delays in the game, especially in the city, until 2 am, especially at night. There is no problem at night and I noticed that while the ping (ms) is 200 during the day, there is a problem of 70 ms at night on the servers.

On the central European server, the ping increases during the daytime. Because of this, I am experiencing a lot of freezing in the game. At night, it is not a problem.

dont touch your bios it has nothing to do with bios, manufacturers will tell you to not touch the bios unless you’re having issues and your issues are with a game not the PC, as far as cpu the coding in this game is horrible and pegs the cpu to 100% to fix cpu temp goto power options>“make sure its on high performance”> advanced power options> click drop down under processor power managment> change under BOTH areas minimum and maximum processor state change from 100% to 90% cliick apply and ok. my temps went from spiking to 85degrees celcius on a ryzen 9 5950x to 55 constantly

as far as tghe gpu update the gpu drivers and make sure its not running in quiet mode i guess i didnt have an issue with gpu
power opt
processor

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.