High Latency connections killing game play

Hi Dev Team,

I’ve been monitoring a strange issue after a few of our company members and server community started to mention lag issues.

I’m on AP Southeast Delos, my average ping is 50-54ms.

When I log in I’m fine, generally the issue starts when I go into player populated area of outpost rush.

What I found was new TCP connections opening from my rig going out to Amazon IP’s but the latency on these are 200+.

From that point on I’m experience lag that I would when I play on 200+ ms, it’s like my traffic is going to NA.

I’m guessing more people are experience a similar issue, there may even already be a forum if so sorry for the dupe.

I ran ‘Who Is’ and confirmed all these new PIPs are Amazon.

Save me before I yeeeet my game and PC in the bin:)

Update: The game is basically just unplayable - I’m constantly getting 250+ ms and so are a number of other on the Delos server. PvE is meh I don’t even want to think of the wars upcoming… Please help…


Bumping this for visibility, because I am having the same issue as well and I am on Lagado (AP Southeast).

Before this issue occurred, I was playing with an average of 120ms, which wasn’t great but was still bearable. Now every time I am in outpost rush, I play as though I have a ping of 250 - 300ms. HP gauges take a second to update after every hit, general stuttering and rubberbanding, non-responsive abilities, all of which makes this game a nightmare to play. I am starting to lose my patience with this incompetent dev team.

The lag is quite crazy the last couple days, damage both outgoing and incoming is delayed multiple seconds and stacks so it comes all at once. PvE is horrible, and I can only imagine how the wars will be tomorrow. Many people having this issue.

Im stuck with 180+ms on Delos. Used to get 130ms. For last 3 days the server lag is horrible not sure what they changed.

Any Devs out there? <3

Hi there guys.

I so sorry to hear that all of you guys are having issue with the high average ping in New World and thanks for let us know about it.

For most connection related issues, begin with the following steps to completely reset and refresh the connection your computer has to the internet:

  1. From the Start menu, begin typing ‘cmd’.
  2. In the results that populate, right-click the Command Prompt result and select Run as administrator.
  3. Type ipconfig /flushdns and press Enter. Wait a few seconds and when the command prompt appears, proceed to the next step.
  4. Type ipconfig /registerdns and press Enter.
  5. Type ipconfig /release and press Enter.
  6. Type ipconfig /renew and press Enter.
  7. Type netsh winsock reset and press Enter.

Also can try these steps too

1-From the Start/Windows Menu, select Settings.
2-Select Network and Internet.
3-In the Status section, under Change your network settings, select Change adapter options.
4-When the Network Connections window opens, right-click your network connection.
5-Select Properties.
6. Scroll to Internet Protocol version 6. 6-Uncheck the Internet Protocol Version 6 (TCP/IPv6) box.
7-Select OK to save your changes for the selected network adapter.
8-Try launching the game again. A PC restart may be necessary.

Please let us know if this troubleshooting steps help you with this issue or not.

Remember leatrix for wow?

Tried all of these steps. Outpost rush continues to be extremely laggy with frequent rubberbanding and delayed reactions or ability activations to key presses. This only happened after patch 1.05.

Same here. Hard lag after patch 1.0.5.

It’s like that for most people since 1.0.5. I would recommend waiting until 1.0.6 since it seems to be on their end. You can still go mess around with setting and your pc, but It will only frustrate you.

Logically all of us did not change anything or do anything to our Internet/PC. So the only thing we all have in common is the patch.

It’s frustrating, but you can only accept it for what it is and try to play.

A lot of this game revolves around accepting the unplayable state, being dead for a week, stuttering, not being able to transfer ect ect.

Thank you for replying @Kagami.

I like others here have tried this without resolve.

Your suggestion would only really make sense if it was 1 maybe 2 players but how this is happening suggests an infrastructure issue on AWS side.

Hopefully this can communicated to the DEV/Infrastructure team so they can resolve this as it is killing the game for most people in AP right now.

im in Perth, this game is absolutely unplayable in any PVP, rubberbanding, massive lag, massive delays causing light and heavy attacks to mis 80% of the time, abilities cant hit anything, I really want to be able to play this game but until this is 100% resolved I will not be logging back on because at the moment its nothing but a waste of my time, with the amount of money amazon has and if you ACTUALY care like you keep saying you do GET A WA SERVER IN PERTH!!!

ye same, wasn’t playing much either the last days, also patch 1.05…not sure what you did there, but certainly has to do with being within reach of other players.

i got a 16 ms ping btw, and it runs well…until it doesn’t, welp

Hi everyone.

Thanks for the clarification. In this case you can fond this post about this issue you all guys are having,

In this post we are gathering information regarding this issue with the high latency and stuttering issues.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.