House Property tax keeps reseting

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Smitherzzz
  • What server/world did you experience your issue on: Andlang
  • Describe the issue you are experiencing: The game says I need to pay for my property tax for my 15k house in everfall, so i click the pay now button and a window pops up saying i paid for my property tax, but no money comes out of my balance, and the property tax doesnt actually get paid. And im just in a loop with trying to pay it but it wont let me. It doesnt let me place furniture in the house or use the teleport. My Monarchs bluff house works fine though, just the house in everfall thats not working.
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: Its awful, I worked so hard to get to 85 furnishing so i can make iron chests to place in my 15k house i just used all my money and bought. Its been weeks since i bought the house i cant use, I thought everyone was having the same issue but no just me.
  • (if a bug) Were you able to recover from the issue: No
  • (if a bug) Please include a screenshot or video of the issue that you have experienced: It just says property tax paid when i click “pay now” and doesnt actually pay it, so im stuck in this loop of trying to pay the property tax and i cant use any of the houses features like teleport or place items in it.
  • What are the steps to reproduce the issue as you experienced: I Bought a house for 15k in Everfall, in like 30 mins i noticed it said pay property tax, so i tried to pay it and its not working

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.