Housing: Cannot purchase 2nd home

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here

To report a player or company for Code of Conduct violations, please do so here

  • What is your character name in New World: RoyalWatcher

  • What server/world did you experience your issue on: Orun

  • Describe the issue you are experiencing: Cant purchase home - ‘Purchase House’ button blank

  • Is this a bug or an exploit: Bug

  • (if a bug) How did the issue effect your gameplay: Cant buy 2nd home

  • (if a bug) Were you able to recover from the issue: No

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

  • What are the steps to reproduce the issue as you experienced: Approach any home - no key bind showing on purchase option

  • When did this happen? (Relative time; please include your timezone) Every time last 10 days…current one 10:30 Central

Hi there!

Thank you for reporting this and apologies for the inconvenience. I just want to let you know that I have properly documented and submitted this game behavior to our team for further investigation. At the moment, we cannot make any promises about a definite fix. Though please stay tuned on our official channels to make sure that you would not miss any update.

Thanks a lot for your help. Have a great one!

thats comforting :crazy_face:

Another one down the drain eh. Lost in the memory hole.

Take yer ease autobot responder; it’s fixed. After much frustration & fiddling, here’s what worked: under Settings > Action, I had to unbind ‘Secondary Interact’ key, which was ‘T’, then rebind it back to ‘T’. Appears to be a fix, at least for me, thx. :sunglasses: