Housing issue, 2 houses I owned got removed from the game

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Hangan
  • What server/world did you experience your issue on: Pangaia Nu/Delos
  • Describe the issue you are experiencing: : Lost 2 houses after patch, one in Windward(20k), one in Brightwood(5k). Unable to teleport or use furnishing items like trophies, storage, interactable chairs, beds, etc. The game somehow does not recognize me as the owner of that house even when I am the current display to the public because I really wanted to show my house.
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: Unplayable, It block all 4 Storage chests from functioning, as well as the 10 trophies I have in 2 of those houses. making the storage now unusable
  • (if a bug) Were you able to recover from the issue: No, tried relog, unstuck.
  • (if a bug) Please include a screenshot or video of the issue that you have experienced: New world House issue - Album on Imgur
  • What are the steps to reproduce the issue as you experienced: None, logged into the game and the 2 houses is just gone.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.