How is this still not fixed? Cannot Declare war!

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: SneakyEyez

  • What server/world did you experience your issue on: Balanjar

  • Describe the issue you are experiencing: Cannot declare war after having done 40%+ influence our company alone

  • Is this a bug or an exploit: BUG

  • (if a bug) How did the issue effect your gameplay: I CANNOT DECLARE WAR

  • (if a bug) Were you able to recover from the issue: NO

  • (if a bug) Please include a screenshot or video of the issue that you have experienced: image

  • What are the steps to reproduce the issue as you experienced: CONTRIBUTE more then 10% influence by doing pvp quests and not able to DECLARE WAR!

Can you guys just fix the game before adding more stuff in and create other new bugs :smiley: ? Thanks

Also saw this today. Contributed approx. 20%
Still confused about it, contributed another few, tipped the scales, and it still didn’t work.

1 Like

That it happened okay I understand sometimes bugs happen, but this shit is going on for a month or even longer and it is still not fixed!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.