HP stuck on set amount

Today i tryed to do the genesis expedition at the final boss i ran in some problems with my hp. my hp suddenly got stuck in 8611 point and i couldn`t increase it by eating or consuming potions. our healer also couldnt increase my hp. i tryed to relog but the problem was still there even after dieng multiple times. my hp could go down but not up. i closed the game to try to reset and that worked however i was kicked out of the expedition and with that i lost my genesis tuning orb. is there anyway to get this orb back because there was a bug with my character?

Hi traveler!!

@ItsDynamite, hope your doing great!

Welcome to the Forums, its a pleasure to have you hear!!

Sorry to hear you lost your Orb for this bug, and your HP bar present an issue that don’t allow it to increase by any in-game mechanic.

In this moments we are not able to refund lost items, by bugs or destroyed by accident.

For your character HP bar, is recommended to contact Amazon Games customer service to provide a better communication on this case.

Thanks, and have a nice weekend!!

there is lot of people lost their orbes because you restarted server suddenly and instantly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.