I can't turn in faction quests and it's making me go broke

I saw another thread on this from October. Doesn’t seem to be any resolution to it.

  • What is your character name in New World: basics
  • What server/world did you experience your issue on: Ferri
  • Describe the issue you are experiencing: I cannot hand in any faction quests in Shattered Mountain. Haven’t tested other regions yet. This has been going on for days across multiple different quests.
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: I can’t turn in faction quests which account for about 600g per day so I’ve lost about 1800g already and it’s just going to keep adding up each day that this isn’t fixed.
  • (if a bug) Were you able to recover from the issue: No.




Two days ago, I completed 3 elite quests in SM and came back to turn them in. I didn’t really pay attention to the UI (because why would I expect my quests to just not register as completed?) and I clicked through the dialogs which ended up abandoning all 3 quests (losing me over 600g). I didn’t receive any rewards and I was still at 3/3 Daily Bonus Rewards.

I tried restarting my game and doing another quest, but same thing. I’ve checked back each day doing a new quest and trying to turn it in, but it’s the same every time.

I’m going broke because of this. The daily rewards are a major part of me being able to pay for the things I need to play the game and without them I’m starting to run out of money.

Would love for this to actually be acknowledged.

I had this for a couple of days, but it was resolved today for me. Has it been fixed for you?

Ayyyy you’re right it’s working today. Hopefully that doesn’t happen again.

I have same problem today. // After two days it is still bugged

Been in the same boat, since last patch. Haven’t been able to hand in a single quest.

Mine bugged again and I am once again unable to turn in faction quests. These kinds of things are annoying, but the worst part about them is that there is no acknowledgement from AGS. This is how people lose hope in the game. When there are bugs that seriously hinder a player’s experience and the player doesn’t even know if the devs are aware of its existence. Bugs are inevitable and I have no judgment regarding them. I just want to be assured that the devs are at least aware of them so that I can have some faith that it’ll be fixed in the future.

@Kay @Luxendra

Still bugged.

Encountering this bug, too. Started after doing my final faction quest (Convenent) and now I get the infinite spinning circle of death when trying to turn in quests.

try doing them in reekwater instead of shattered. for me shattered/edengrove is bugged but nowhere else.

still bugged

Was able to start doing Faction Quests in bugged areas (my bugged area was Edengrove) by going into the Quest Log, abandoning the completed Faction Quests that couldn’t complete/turn-in, then taking a new set of quests and completing those.

Basically the solution is to refresh the quests because the old completed Faction Quests are no longer recognized, post-patch/post-merge. I can’t remember if I picked up these Faction Quests before or after the big Winter patch or server merging announcement/downtime. However, any new Faction Quests in Edengrove now work/complete properly.

Hopefully this works for other people. It’s a pain to have to lose that completed work, but better than being potentially stuck forever not doing Faction Quests in the area you’re working in.

Reset the quest, did it again and still won’t let me turn in faction quests for multiple areas.

Curiously, did you reset the quests or did you abandon the quests? There’s an option to ‘reset’ on some quests (that doesn’t abandon it), so wasn’t certain what solution you attempted. Simply resetting quests didn’t work for me either. However, after completely abandoning the faction quests, I was able to get completely new/different ones to do that didn’t cause problems upon completion. They must be abandoned by Quest Log (they cannot be abandoned/cancelled via the Faction vendor interface).

However, if you’re abandoning quests and the completely new quests aren’t working, I would put in a support ticket. The aforementioned ‘abandoning quest via quest log’ solution has worked for me and my friends that had stuck faction quests, so I’m unsure of what issue you could be encountering if that solution doesn’t work.

I abandon them.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.