Ice Storm still bugged and only 1 ticks

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: DaySpirit
  • What server/world did you experience your issue on: Eden
  • Describe the issue you are experiencing: Ice storm only does 1 tick of damage and then does no additional damage. It is an AOE attack but only hits one time instead of multiple times as it is supposed to.
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: I can’t use the weapon as it is useless without it’s AOE. Mobs and bosses in endgame have massive health and do massive damage, the players need strong AOE to fight them.
  • (if a bug) Were you able to recover from the issue: No. I’ve tried respecting, leaving the last perk off etc but it’s been this way for weeks and was supposed to have been fixed in the last patch but persists as a bug.
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced: Play with the ice gauntlet.

The behaviour is intended. Ice Storm works. The only mobs where it does tick only once are Bosses and that is intended. There is nothing wrong at that point.

So every single AI in 60+ level areas is a “boss”? I’m not talking about named bosses I’m talking about mobs as well. Angry Earth, Reekwater lost in Forcastle drift. They all one tick and I’ve had it happen with animals as well. I actually respeced leaving off the last perk as people have said that’s where the bug is, and it worked for a couple hours but they bugged out again and went back to one ticking everything.

Per the patched notes just released it’s the unending thaw perk causing this bug. Went and tested taking off the armor with that perk and ice storm now works. Hopefully this patch fixes it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.