Imhotep not spawning - Devourer

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here

To report a player or company for Code of Conduct violations, please do so here

  • What is your character name in New World: saucytates
  • What server/world did you experience your issue on: devourer
  • Describe the issue you are experiencing: imhotep is not spawning for the quest challening the pharaoh
  • Is this a bug? (If this is an exploit, please follow the steps here: [Dev Blog] How to Report Exploits - Updated)
  • (if a bug) How did the issue affect your gameplay: cant complete quest
  • (if a bug) Were you able to recover from the issue: no
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced:
  • When did this happen? (Date and Relative time; please include your timezone)now
1 Like

30 minutes waiting and nothing

Thanks so much for reporting this bug @saucytaters I have passed this along to the dev team!

Were having the same problem here on yonas. Been hanging out here with the goats for an hour.

bump @Talon

12 days since they “passed this along to the dev team” but no resolution. meanwhile hundreds of people on our server can’t progress the main story quest. that’s pretty pathetic ags

Bump, still not spawned on Yonas

1 Like

I’ve checked both Devourer and Yonas and he seems to be spawning just fine. Let me know if that changes.

Yonas Fixed yesterday. :slightly_smiling_face:

1 Like

I’m having the same issue on Minotaur. Over an hour waiting and no spawn. I could have been mining!

while fighting Imhotep he teleported and ended up down here in a state where I can’t interact with him. I imagine he will just remain stuck here ie. not respawn.

character: Treasonist
server: Devourer