Inspire Armorer's Town Buff not working

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Zappafrank
  • What server/world did you experience your issue on: Orun
  • Describe the issue you are experiencing:
    The Inspire Armorer’s Town Buff is not giving +5 even though it shows as active on the town management table w/ more than a day left. I own a house in said zone and have my taxes paid.
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: GS of crafted gear is lower than it should be
  • (if a bug) Were you able to recover from the issue: No
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced: N/A
3 Likes

It was working pre a corruption invasion, but was not working after. I changed nothing else and the Forge was not downgraded.

-I’ve checked all my skill bonuses multiple times.
+25 From Skill
+45 From Materials
+15 From 5x +2 armor pieces and a +5 earring
+15 from food
+15 from 3x Major Armor Smithing Trophies
++5 from owning a house in a region with an active Armorer’s Inspiration town buff.
-I’ve picked up and replaced all of my totems ensuring that it lowered my GS range after each pickup.
-I’ve equipped my gear pieces that provide bonuses and watched the range shift by 15 after relogging to clear the visual bug
-I’ve bought a house in a new town that also had the buff active.
-Attempting to craft using T5 forges in multiple towns, including the town I have a house in with the active +5 buff listed at the Town Hall table.

No change, Still only able to craft in the 590-600 range.

After spending 400-500 hours leveling armoring and acquiring every possible buff, it’s hugely demoralizing not to be able to craft those gear rolls that I have been chasing.

Please Fix.

2 Likes

The town I have my third house in just completed an Armorer’s inspiration Buff, so I have the buff active in all three town, still no +5. Hopefully it will start working again once the first buff clears.

1 Like

After the buff in the initial town expired, we purchased another buff and completed the board quests. The buff shows as active again on the table.

No change,

1 Like

+1 It doesnt work. I have 200lv Craft, 3Trophy (tir 4), V tir cooking, full set(25) and earring. and i have a house in everfall. It still 590-600. Why? I try replaced trophy and relogin, nothing change.










I have the same issue. Game doesn’t recognize our houses I think that’s the problem.

Mines are not working neither PLEASE FIX

Not working me after buying a house, I got buff listed in the city-buff section, but no effect on crafting

sad bump for a bug that will never be fixed because it affects only a minor population that can be discarded

From what I can tell, it now just appears to be a visual bug for me. I did a test run when it says 590 and was not getting lower than 595.

This bug very important! FIX this pls.

Anyone else can confirm that there is no visual only? But crafts get +5 bonus?

Same issue, stuck at 586-600 (every buffs + 2 trophy basic and 1 minor).
The Inspire Armorer’s Town Buff is active but bonus +5 is missing.
I have a house in this city, controled by my company. Also, tax is properly payed.

I can confirm about the Armoring buff.
It displays ‘590-600’ GS but there are no items crafted less than 595 GS for more than 20 crafts.

Seems only a visual bug here.

Bump. I can confirm as well. The +5 has a HUGE impact on endgame crafting. 595-600 vs 590-600 means that you would have to roll TWICE as many times to hit 600 GS. This is an insane cost difference at this level.

PS. I am very happy with NW overall and love the game. This so far has been my only real complaint as I love crafting.

Was this bug fixed in patch 1.1?

bump