Issues running New World and Twitch app at the same time

Not sure if it is just me but when I play the game and run the Twitch app at the same time the game tends to crash and “pause” every so often.

I have 2 monitors. I play the game on one and watch Twitch streams on the other. Before I start the game the stream has no issues (buffering or dropped frames). After I start the game the Twitch stream begins to freeze. Once playing the game I experience pauses in the game which can either fix itself after 30-60 secs, drop me to the main menu after about 20 seconds, or drop me to the desktop with no messages. Every once in a while it crashes the computer and it reboots.

i have played with the Twitch app completely closed and I can play the game for hours with no issue.

I post this more of a curiosity if anybody else has the same issue than just complaining. I hope maybe it is a real issue and not just me.

I am running a 5950x with a 6900xt and 32GB of RAM. I have already run DDU and tested for Windows integrity. I don’t think my system should be having any difficulty streaming while playing the game.

I am having too much fun playing the game for this to stop me but if it can be fixed it would be wonderful

cheers

Hey @punkr ,

Greetings!:slight_smile:

I am sorry you are not able to run both New world and Twitch together.

I recommend you trying the following basic troubleshooting steps once:

-Run Steam and New world as admin
-Run Integrity check-

Run Twitch as admin:

  1. Go to your start up icon, right-click the Twitch icon.
  2. Click on More > and then Select the Run as Administrator option.
  3. Accept the prompt.

Restart PC and relaunch the game.

Optional
Re-link both Twitch and Amazon accounts and check for twitch settings in game.

The steps mentioned below also help with game crash issue -

1.Files integrity check.

  1. Easy Anti cheat Repair-
    repair or reinstall EAC, instructions are here: Easy Anti-Cheat
  2. Disable temporarily firewall .
  3. Disable Ipv6
    a.From the Start/Windows Menu, select Settings.
    b.Select Network and Internet.
    c.In the Status section, under Change your network settings, select Change adapter options.
    d.When the Network Connections window opens, right-click your network connection.
    e.Select Properties.6. Scroll to Internet Protocol version 6.
    f.Uncheck the Internet Protocol Version 6 (TCP/IPv6) box.
    g.Select OK to save your changes for the selected network adapter.
    h.Try launching the game again.
    5.Use the System File Checker tool to repair missing or corrupted system files.

Check for all the updates for drivers.

If issue persists,kindly respond back with screenshot of error(if any) so we can escalate this further.

Thanks!

Happy Holidays! :sunflower: :christmas_tree:

I think i have the same problem as you right now. But previously before the patch, i have no problem withsoever with my 1582 hrs playtime. Now i keep getting freeze then unfreeze, sometimes when you re-log too many times u will get msg “Login Blocked: Suspicious Software or Corrupted Install Detected”. And if you notice, when you at the loading screen… your character starting to load very slow. It’s like server and server-data issue to me. Some said its server related issues :frowning:

Thank you for the info!

I have tried to be systematic with working through the solutions to see what helps. Although none of this is scientific…

game integrity checks and system integrity checks have always been good…

running game and twitch app as admin : this seemed to help but i eventually did see crashes that interrupted the game and twitch app…

what has seemed to be most stable on top of running both as admin is to disable IPv6. i will continue to play and see just how much. I got one crash after disabling IPv6 and there was actually an error that came up but it cleared before I could see it as the game completely exited after clearing from the freeze. I have never seen an error before with the issue I was seeing… so this might be an improvement or some other crash…

on another note it would be nice to see an optimization driver update from AMD for New World… but that is just me being hopeful :slight_smile:

1 Like

so here is where i am…

IPv6 is off
running steam as admin
running twitch as admin

i am still getting 40-60 second freezes that either end up with me back at the main menu, rubber banded back in time, or game crashes. i still see whatever twitch stream i am watching freeze as well. when the game comes back so does twitch.

it has already happened at least 4 times since playing on and off for the past few hours.

thank you,

punkr

This is still happening… last night playing for a few hours it happened at least 4 times… one of the times it sent me to the main menu and said it detected lag…

are there any logs i can check to find out more detail of what is going on so i can tell if it is me or the game?

thank you,

punkr

p.s. - still no optimization for amd drivers… hopefully soon…

today i disabled twitch at startup… so it never started…

i still got freezes for 40-60 seconds that either crashed to desktop with no message or resumed the game with all the buttons i pushed during the freeze… so it doesn’t seem linked to twitch…

please let me know if i can gather logs or something to stop these freezes from happening… tonight it happened at the last boss of dynasty and i was healing… so it was not helpful…

thank you

punkr

Hello @punkr ,

I hope you are doing good. :slight_smile:

Thank you for keeping a check on this.

Please PM me logs and dxdiag report along with character name for further investigation.

Instructions for generating a DXdiag: Open and run DxDiag.exe
Instructions for finding the in-game logs:

  1. Press Windows+R on the keyboard, type %appdata% and press enter.
  2. Open the most recent file from this folder: /AppData/local/AGS/LogBackups.
  3. Paste the contents of the file in a txt file and send it as an attachment.

Thank you :slight_smile:

1 Like

i have the dxdiag and latest game log. I tried sending you a PM but it says you aren’t accepting messages at this time and also there was no way to attach files in the PM… please let me know where you would like me to send them…

thank you,

punkr

Hello!

I am so sorry for the inconvenience.

Please try sending now.

Thanks.