Issues with EVGA RTX 3090 FTW3 Ultra

It’s overheating, plain and simple. And if you’re not running something like MSI Afterburner, you won’t notice it. I already posted a similar issue but in my case with EVGA RTX 3080 FTW3 Ultra.

The “solution” in my case was - and I can’t stress this enough - LOCK the damn game to 60 fps from the settings. My temps dropped drastically when I locked it to 60 fps. Do NOT under any circumstances run it “Uncapped”, there is a high chance it will brick your card. Obviously it doesn’t happen to all GPUs and to older GPUs but in the case with 3080s/3090s at least, they’re running hot in general and for some reason this game eats them as if it is mining bitcoins or running stress tests.

Just LOCK it to 60 fps until (if…) this gets fixed.

1 Like

I’ve ran plenty of stress tests over the 8 months of owning this card with zero crashes. Yet this game’s menu crashes it.

Considering the time and resources spent on this game, I can’t believe they don’t have an auto frame cap in the menus like every other game that has released in the last 5yrs.

Definitely - that 30C makes a huge difference! If you plan to jump back on NW today let me know how the hardware holds up.

I used to run MSI afterburner for ANYTHING , since my PC was having these issues with Fall Guys , Valheim , …

AC Valhalla and Cyberpunk etc , I could run these non stop with no issues .

I had the issue a first time with Fall guys , then with Valhalla and later even with WoW Classic … but running MSI afterburner fixed the issue cause I could prevent voltage pikes when the Mhz was fluctuating…

now with this , even MSI afterburner won’t help , I keep getting the crashes , can’t even enter settings , the game boots , starts loading settings screen or login screen w/e , I dunno what screen it loads cause it goes straight to crash …

is there any way I could be putting in that frame limit without entering the game ?

Sure. You can do it from NVIDIA CP or Riva Tuner. Easiest way is from NVIDIA Control Panel - open it, go to Manage 3D settings—> Global Settings —> Max Frame Rate.

Good morning, @Adam_F

GPU’s. Game fried two EVGA RTX 3090 FTW3 Ultra video cards. Yeah it sucks.

I will be honest, I did not check that out. I just assumed that bricking 3090’s was not a “common issue”. If it is considered a common issue, we are all doomed my man.

Here is the info that thread asks for though.

All Drivers and Bios up to date.
CPU: Intel Core i7-10700K
GPU: EVGA RTX 3090 FTW3 Ultra
RAM: Corsair Vengeance RGB Pro 32GB
HDD: (game installed to primary OS storage, or secondary drive?) Primary m.2 SSD
MOBO Model: ROG Strix Z490-E Gaming Z490
Mobo BIOS Version: BIOS 2201
Windows System Version and Build Number: 10.0.19043 Build 19043
Server (Region): US East
Physical Location/Region (i.e. Rome, Italy): MI, USA
Internet Service Provider: Comcast
Error messages you are getting: None
What is happening?: Two EVGA RTX 3090 FTW3 Ultra died. 1 card died from playing the game, the other died from just trying to launch the game. Both cards went 100% load, monitors shut off and now cards cannot be detected on PC bootup during post.
Where are you in the process when you run into the trouble? (e.g. When I leave tutorial and enter the world, launching the game, teleporting to an outpost in Weaver’s Fen, etc.) Launching the game, did not even make it to the Amazon Games screen that pops up right after launch.

Hope this helps. Considering the posts on this thread, this really needs to get to the engineers and developers, seems we got a major issue here.

Thanks.

1 Like

I was locked to 60, and running steady temps in acceptable ranges. Card died after 45 minutes of play. It’s good advice to not stress your card, but there’s something else at play here I think.

The issue is with EVGA, is not from Amazon either NVIDIA, it was a known issue from time ago already, the game runs great, it uses the 100% of the GPU meaning there is no Bottleneck at all, it uses all the power the GPU can offer.

Sounds like VRMs poorly cooled / sloppy model from EVGA, like I said, a known issue already from this manufacturer.

Thank you.

Seems like EVGA also not reacting to it for now.

If your card bricked with this game then It would have bricked with a simple stress test in Furmark too, like I said the game has nothing to do with the issue.

Apparently there are people playing multiple other games only to have the card break in New World.

The game is literally the issue

I personally know 2 people who have had their 3090s bricked from playing this game

1 Like

They are all EVGA card owners, im playing perfectly fine in my ASUS Rog 3090, temp around 72-73 in 4K limited to 144FPS.

Yea, no. When I was overclocking my 3080 FTW 3 Ultra to the absolute limit, I ran multiple hours, even days for stability. FurMark, 3D Mark, Unigine and a few others. It never failed after 8-12 hours sometimes, it never crashed. Yes, it reached high temperatures for obvious reasons but it was working completely stable. Needless to say it never reached higher than 65-70 C* in any game, let alone overheating so severely.

Right now my card is UNDERvolted and UNDERclocked and if I run uncapped FPS in New World, it reaches temperatures higher than when it was overclocked and running FurMark.

So yes, the game has everything to do with the issue.

1 Like

All the users I keep hearing that have issues are EVGA Card owners, you are also one so dont you think the issues are with your card assembler?

I just had the very same problem with different graphic card KFA2 2080 Super

I have a 3090 Zotac, no problems at all, played like 2 hours the game… but reading all of this, I’m waiting to Amazon Studios bring a fix, I’m not playing anymore.

1 Like

I have a 1060 video card - 100% memory leak. I will not play the game until the problems are fixed!

1 Like

So I agree with you that issues exist on the EVGA RTX 3090 FTW3 Ultra side for sure, 100% without a doubt this card is having issues with this game more so then others, i mean they are just simply dying to New World. But I am finding other cards are having the same issue, just less frequent. Also a whole lot of cards are running this game above 80 Celsius, working but running HOT, even with capped frames.

All this is a recipe for disaster. So I just think both sides need to get on this ASAP. Amazon Games and EVGA. My brothers 2080 runs @ 77 Celsius but is working, my wife’s 3080ti is working but running the game @ 82 Celsius. Both on medium settings with frames capped. This is insane, we dont hit these temps on max settings in any other game or even stress tests.

I’ve got a Gigabyte 3090 and it does the same thing that others have described. Fans max out and screens go blank just trying to launch the game. Plays any other game without breaking a sweat. I wish you luck on your 3090 surviving. Playing this beta isn’t worth the risk to my video card.

1 Like