I've teleported all day, spent 1500 azoth trying to switch severs the way it was suggested. It isn't working!

-What is your character name in New World: Bold Sir Robin
-What server/world did you experience your issue on: El Dorado, switching to Yggdrasil
-Describe the issue you are experiencing: Unexpected error, lost communication to game server
- Is this a bug? Poor Programming( My guess is they switched the token’s name from ‘World Transfer’ to ‘Character Transfer’ and now there is an issue with the tokens communication to the servers, potentially duplicated the tokens leading to the server trying to communicate with the old one named ‘World Transfer’ and not the new token named ‘Character Transfer’)
-(if a bug) How did the issue effect your gameplay: I 've spent today trying to switch servers so I can play with my friends who have left this server before the programming of the token was changed. I have spent money on a new one thinking it was the free one that was broken, derp.
-(if a bug) Were you able to recover from the issue: No, scarred for life. xD, nah just get my character switched over before I decide this game is a Lost Cause, I took a break for 5 or 6 months, have a powerful character that I worked hard on and will not spend that (ridiculous amount of) time doing it again. I’ll just get healthy instead xD
-(if a bug) Please include a screenshot or video of the issue that you have experienced:

-What are the steps to reproduce the issue as you experienced: Try and Server Transfer, in fact it’s been replicating itself countless times now.
-When did this happen? (From 2022-09-14 mid day Mountain time North America, until today is 2022-09-18, is 6:45pm) I’ve talked to many levels of Support from emails, to phone calls, to researching on forums on the first day and following the steps given in all three of those mediums. I’ve even logged in at a friends house who had no problem a couple weeks ago transferring, still gave the same message on a different computer, different network, where it previously worked not long ago.
It would be great if Amazon could just move my character for me, and maybe have that token i purchased made into in game currency or something, or allow me to gift it to someone lol. I know it’s probably a lost cause but eh, got to make noise to be seen or nothing will be done.
I read people were able to transfer by teleporting to different shrines, i’ve been to every shrine, and town, and tower now.

Please fix this issue, tried again today and I still cannot transfer, same problem.

Hello @PSi4,

Welcome to the New World forum, I’m really glad to see you are here at the forums and hope you can enjoy your time here and at the game as well!

I’m really sorry that you’re having this issue with the game transfer, this is clearly a huge inconvenience and I apologize for it, here’s a useful article that might be able to help you:

In case this doesn’t work I can recommend you to reach us via player support using the following link: Contact Us | Amazon Games to create a support ticket and review your case in more depth.

Please make sure to add this post link, as well as the DxDiag and Gamelogs through a sharing link from a Cloud Storage like Google Drive to the support report, you can pull it following this steps:

DxDiag report:

  • Go to Windows Start search bar and type dxdiag.
  • Click on dxdiag.exe.
  • When green progress bar goes away, select Save All Information and save the file to their desktop.

GameLogs:

  • Game logs can be found on: \Users\USERNAME\AppData\Local\AGS\New World\CrashDB\reports\

If you need further assistance in any other issue please don’t hesitate in reaching us again!

Cheers!

is this issue resolved? I am having the exact same issue.

Hello @Xano,

Thank you for your post but please avoid double posting about the same issue. You can read up on the answer to your question here:

See you in Aeternum! :wolf:

Still is a problem, i cannot transfer, please fix!

Hello @PSi4,

I am sorry to hear you are still having this issue. Please give the troubleshooting within this post a try and, if the issue persists, note the next step listed by @Wyvernn is to contact support via the links they provided.

Good luck and see you in Aeternum! :wolf:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.