Lag Detected followed by Stuck Character "Time since last response:" until disconnect

best of luck, im at 250 in a 3k queue, so my foolish hope keeps me from requeuing yet, its like 6hrs…

1 Like

Username: Mo Powah Baby
Server: Xibalba

If a support person sees this message please fix the Lag Detected issue on my account. I first encountered the bug after fast traveling to a town running a bit and then the message popped up and I was stuck. Chat was still moving and had full interaction with UI elements. This happened at about midnight last night. I logged off hoping it would fix itself. It has not.

So I contacted support, a second time, I’ve explained about my bug in specific and DayOfJustice’s but I went into depth about how we’ve tried the vast majority of the “potential fixes” and how we were originally playing normally and can’t even move anymore. - I’ve linked them this thread which he claimed to have immediately sent to the Developers & claimed that they’re reviewing this thread right now. - Apparently there may be a server maintenance soon which could also help us.

That’s about all I can share…I’m sadly sceptical because I’ve seen no progression/further help since yesterday towards this bug but here’s to hoping, right?


same issue. ive tried everything under the sun that has to do with connection troubleshooting… its a character issue

East Coast Pahruli. Character…peepeepoopooboi

Someone can help?

as @DayOfJustice is writing there are basicly different issues.

Probably it makes sense to focus on this specific issue described by @DayOfJustice here and not confuse everyone too much.

From my understanding thats basicly players which were able to play the game without any disconnects or laggs before and suddenly at one point they can’t do anything anymore and not move for one meter after login.

I am one of thoose players and i am quite sure this is a character specific issue which needs to be fixed on server side.
I have installed New World fresh on a second workstation and used Internet via my phone and still i am not able to move the character after login.

I have all the symptoms described by @DayOfJustice . Only difference i was able to invite one of my friends into a party and he could also accept the invite and “see” me in the map. But he told me i am in the Inn while i see myself somewhere totally different after logon.

Also hoping for either a server restart or any actions beeing taken from GMs/Support.


This way we can compile the information for the devs to hopefully get us help faster.
This form will also be linked at the top of the original post.


Done - Great way of compiling information.

1 Like

just got a vpn and tried to go east, west, another country… nothing worked

100% agree here. I myself have the exact same issue as Justice and I’d like to see just this specific topic/bug discussed as apposed to a wide variety of different errors. If we can split our forums up so bugs don’t overlap, perhaps we can all work together with the team to get these fixes easier/faster.

Good words, friend.

1 Like

I have Telenor fiber.
But Ownit uses telenors fiber.

I still had no issues since I started using a vpn today, played all afternoon / evening.
I did get 1 lag detected around 19.00 ish however, but it was for like 1 second, then back to normal so no issue at all.

But ye, just because it seems to work for me does not mean it will work for everyone else.

Obviously I would prefer to play without a vpn because it slows down my internet overall, and ms is slightly higher. But I take that over not being able to play at all.

i’ve done my report in headcount, hope this will help devs for working faster on a fix


What VPN and where have you routed it to?

@niv YE if Ownit usese telenors Fiber then thats the issue i guess. Cuz as you said. I have been playing now 2h, No issues just sometimes i kinda get a small delay in ability like every 20min. So VPN deffo helped us

If ppl wonder. We got VPN and Changed it to our country and we dont get the Lag Detected anymore, but it doesnt work for everybody. Specificly only worked for mine and @Niv “lag detected issue”

Sorry for my english, cant be asked now to be “proper” :slight_smile:

That’s what I tried, got back to position 3871. Unluko for me. ¯_(ツ)_/¯


1 Like

Done! same problem here

1 Like

Same issue… Server Thule EU Central Character name Ibissa (filled out the form too) and back in 1.5k queue… this gets pretty much unbearable


I just got in game and the issue has seemed to resolve itself

1 Like

When i check the game menu it says diffrent servers under World everytime i log on but never the server i actually chose lol

1 Like