Launch Error - Product Information not found

Greetings Adventurers!

If you receive the following error message “Product information not found” when attempting to launch New World.

If you encounter this error, you may be able to resolve it by turning IPv6 off:

  1. From the Start/Windows Menu, select settings.
  2. Select Network and Internet.
  3. In the Status section, under change your network settings, select "Change adapter options.
  4. When the Network Connections window opens, right click your network connection.
  5. Select properties.
  6. Scroll to Internet Protocol version 6.
  7. Uncheck the Internet Protocol Version 6 (TPC/IPv6) box.
  8. Select OK to save your changes for the selected network adapter.
  9. Try launching the game again.

Should you still encounter this error and are on a Windows Preview Insider build, please roll back to a stable build of Windows 10, as we are not currently supporting Windows Insider Builds.

Safe travels in Aeternum!!

4 Likes

I would like to mention that this fix worked for me as well, without being on a preview insider build. I am on OS build 19043.1110 and was getting this error. I originally ignored this because I am not on a preview build, but this fix worked for me on a stable build as well.

2 Likes

I did what they wrote and I still can’t get in. :frowning:

2 Likes

So didnt have the setting checked. Am i just screwed lol

1 Like

@J_Huep, I am encountering the same error, except the game was working perfectly last night. After the patch today, this happened.
Have followed all steps including reinstalling game and running as admin.
OS build is not insider.

er… never mind… rebooted my router and it has mysteriously fixed itself…

1 Like

Worked for me.

1 Like

or
if you have more than one wifi router, try another, my spectrum wifi had the error but my
Mercku Hive M2 Mesh wifi did not

I am encountering the same issue: I have played New World for days without issues… Now I can’t launch the game.
I did not get any windows updates, my network did not change…
I tried all suggestions, but I cannot connect…
Any other solutions? As I do not understand why I have been able to play for days, but cannot launch the game now…