Lazarus from Chilla onwards Bugged

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here

To report a player or company for Code of Conduct violations, please do so here

  • What is your character name in New World: MyPharaoh
  • What server/world did you experience your issue on: Styx
  • Describe the issue you are experiencing: Everyone in our group cleansed the hands but Chilla didn’t want to fight us. We could see that our objective was to Return to Chilla, but upon interacting with her, she simple didn’t move. We tried to kill ourselves by jumping into the water, which didn’t help either. Our tank got respawned somewhere else so we assume it was an issue with him. After meeting again at the closest respawn we went again to Chilla and we could finally fight Chilla. However, again our tank had issues. He made 0 damage, but also took 0 damage. This kept on happening throughout the remainder of the expedition. Also even though we team wiped, it didn’t count as a team wipe in the summary screen.
  • Is this a bug or an exploit: bug
  • (if a bug) How did the issue effect your gameplay: we couldn’t get Gold
  • (if a bug) Were you able to recover from the issue: nope, Orb lost
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced: first time it happend

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.