Logging into the game

Good evening after this last update yesterday i am not able to log in. when i open the game it will not get passed the first slash screen. has anyone else had this issue?

1 Like

try reinstalling EAC or using a VPN, these are the only two method that seems to work. the second one is better

Hello @lindithompson03,

Welcome to the New world Forum! :space_invader:

I’m sorry to know about the inconvenience with New World. May i know the troubleshooting you have tried?

You can also try:

I’ll wait for your reply! :space_invader:

i have verified 3 different time, i have uninstalled and reinstalled 3 different times and windows and nvidia are both fully up to date. this is the first time this has happened in the 840 something hours i have on the game.

Greetings @lindithompson03

Hope you’re doing well :slight_smile:

Could you please try these steps :

  1. Uninstall the game
  2. Delete these folders :
  • C:\Users(your comp name)\AppData\Local\AGS
  • C:\Users(your comp name)\AppData\Roaming\AGS
  1. Reinstall the game.

Please try these steps and let me know if you’re facing the same issue.

We’re always here to help you.

i followed those steps and reinstalled the game and still nothing

Hello @lindithompson03!

I’m sorry to hear you still experiencing the issue after trying the steps.

At this point, if you still experiencing the issue when trying to login please contact our support through chat here: New World - Support | Amazon Games

They will ask you for the logs and Dxdiags, if you don’t know how to get that info please take a look in the following steps:

  • Provide 5 logs from: Users\AppData\Local\AGS\New World\LogBackups
  • DxDiag report: Go to Windows Start search bar and type dxdiag. Click on dxdiag.exe. When green progress bar goes away, select Save All Information and save the file to their desktop.

Take care & stay healthy! :man_mage:t3: