Login blocked. Suspicious Software detected -> Fixed

the appdata may be hidden. go to C:\Users\Name and type the rest \AppData\Local\AGS

Yeah I tried that. Nothing found. Any idea?

try searching for AGS folder

Okay found it now. Deleted the New World folder inside it.

Its not verifying any game files tho

Still got kicked after 5 minutes again.

Experiencing the same thing… NW is unplayable.

If you are using Overwolf, and the Aeternum Map, this might be why.


Make sure OCR/Screen Capturing is turned off.

Would also recommend trying to reinstall EasyAntiCheat

I found my fix. I located the asked folder by going to C:\Users\Name and searched for \Appdata. Then I searched for \Local and went there. After that I searched for AGS and deleted everything in there. After that I started Steam as admin and pressed right-click on New World. Then I chose “Properties” → “Local Files” → “Verify integrity of game files”. This being done I started the game and had no issue anymore.

1 Like

Gonna wait till devs do their job. Every second player has this several crashes and login problems since update.

I have tried to do this but am unable to find the folder AGS. I thought for sure this would solve my issues as well.

Open a “run” prompt and paste this: %localappdata% and the follow the instructions

I had to do a google search but for Windows 11 it seems that what you have suggested is a little off. For Windows 11 people : %appdata% is the actual proper search term to find the AGS folder etc. Am waiting on a reinstall then will try NW again, but do not have faith it will work. My user account in Windows 11 may be to blame, corrupted etc. If so, I may do a total re-install of Windows, but likely not Windows 11 this time. Probably going to go back to windows 10 after this fiasco.

sorry, not familiar with windows 11 differences or why that wouldn’t exist, but best of luck!

repairing steam files solves the problem.

1 Like

How You do it?

Start Steam and right-click on New World in your library. Then I chose “Properties” → “Local Files” → “Verify integrity of game files”.

yesitsphoenix gave you the answer

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.