Lost items while trading

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Treubruch
  • What server/world did you experience your issue on: Muziris
  • Describe the issue you are experiencing: Gave a company mate the materials to upgrade my trophies from minor to basic. He did and traded me the basic trophies for ancient, wildlife, and corrupted. All three trophies were in the trade screen and locked for trade, but when the trade was concluded he corrupted trophy was missing from both of our inventories. I tried relogging but the trophy was still missing.
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: Lost the Anciant basic trophy (and therefore the materials required for it)
  • (if a bug) Were you able to recover from the issue: No, the trophy seems to have been lost during the trade.
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced: Not entirely sure. Maybe accepting the trade as soon as it is locked not giving the game time to recognize the last item selected for the trade?

Mintolos on Miminsbrunner just had the same issue happen on two basic corrupted trophys

I lost the exact same trophies in trade.

3 x Basic Ancient Combat Trophy.

Making a bug report with video.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.