[Megathread] New World Update 1.5.2 Bug Reporting

Greetings Adventurers,

We are creating a weekly thread in order to track new bugs that popped up due to the most recent update, the 1.5.2 Update.

You can find our Known Issues list for the Arenas Update here and the Update 1.5.2 Feedback Megathread here.

Please use the template below so we can get as much information possible to provide to the team:

  • What is your character name in New World:
  • What server/world did you experience your issue on:
  • Describe the issue you are experiencing:
  • Is this a bug or an exploit:
  • (if a bug) How did the issue effect your gameplay:
  • (if a bug) Were you able to recover from the issue:
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced:
  • When did this happen? (Relative time and timezone)

We thank you for helping us improve New World and for keeping this thread solely on the bugs and exploits you are experiencing.

1 Like

We had a Dynasty Instance Crash - I believe all the groups running were affected

We initially got “LAG DETECTED” - followed by a kick to the title screen “lost connection to server”

When I closed & ran the game again, reconnected - everyone was outside the Dynasty entrance b*tching about whole groups disconnecting & wasted their orbs

Server:

Delos - AP Southeast

Server Time AEST:

2022 June 09 - around 01:00 AM’ish

It seems there are massive memory leak issues in open world that get more severe with the more players present in that open world zone. It is especially noticeable in Great Cleave. In addition, there seems to be some severe frame-rate issues that worsen as the memory leaks get worse, and they appear to look like every ~10th frame skips. I don’t have epilepsy, but this bug might give it to me…

Character name: Whomptimus
World: Pluto

4 Likes

Topaz Gypsum Potion giving 15% Resistances to Void DMG

image

image

image

2 Likes

Bought two 600GS great axe’s from trading post, and two gems to attach to them. I get the message “no gems available” when attempting to attach a gem to my newly purchased weapons. However if I try the same thing with one of my existing gemmed weapons, the replace gem option shows and I assume (don’t want to waste the gem) would then work.

So this issue seems to be with newly purchased weapons only.



*edit on further investigation diamond gems show as an option just not cut pristine saphire or topaz

you can only attach elemental gems that match the shirking element on your weapons. i.e. you’d need a ruby for your shirking flames GA and an Amethyst for your shirking abyss. Diamond is neutral so makes sense it’s an option.

1 Like

Mouse not locked to screen.

The windowed game, mouse leaves screen while clicking and using abilities.

I’ve never had this happen before this update, i’ve been using windowed mode for pretty much the entirety of new world’s existence.

5 Likes

thanks that makes a lot of sense, cheers for clearing that up

light-heavy-skills targetting allied/friendly pylons anyone?

It’s driving me crazy, you can’t try to use a light/heavy or a skill that your homing will redirect you to the nearest pylon, be it friendly, neutral or foe.

I haven’t been able to place a camp since the update. Pressing Y does absolutely nothing even though the key is bound. Have unbound then bound the key again, and tried other bindings for that action, no luck. Pretty annoying having to rely on others’ tents since i can’t make my own…

I don’t think it’s a bug. It’s been like that since they added the potion to the game.

This is not fixed.

It is still happening on OPR after you respawn, you will have the one weapon highlighted and it will try to cast abilities of the secondary weapon instead and completely bug out.

1 Like

like this lol

Yes exactly like this, super annoying.

Isn’t that corruption, not void? I thought void was arcane

lol unreal.

most of the shots taken in OPR or attacks swung are missing and going through players. It’s another disaster but at this point its just expected and I’m surprised.

No void is defined as Corruption, arcane is Arcane. Corrupted mobs are Corrupted. Probably some history dev thing.

Go to an existing camp and change to the default skin and it will work - there is an error with a few of the paid tent skins.

Shirking and keenly buffs proc do not show buff icon on bar.

Blunderbuss passives not proccing. (or not displaying buff icons)


image
image
image

Compare to PRE-1.5.2 patch, encircled the buff icon and scrolling text

2 Likes