Mob and quest resets several times

My problem is of two parts.

  1. Game is using 100% CPU usage.
  2. Game has random glitches where my quest is broken.

System Details
CPU= 12th Gen Intel Core i7 - 12700F
Memory= 64 Gb 3200 Mhz DDR4
GPU= Nvidia RTX 3070

Live Stream cut down and edited Version of what happened.
-----------------------------------------------------------------
Update 11/28/2022 4:45pm
Bios update did not fix the issues…

Update 11/28/2022 4:31 AM CDT

So I was in game in global chat and some one mentioned about a bios update… Turns out there was one for improvement on my chip…
https://www.msi.com/Motherboard/MAG-B660M-MORTAR-WIFI-DDR4/support

  • Description:
  • Update CPU Micro code.
  • Enhanced memory compatibility.

This update has seemingly fixed the pinned cpu at 100% while playing the game…

Thank you for all your help but I think I am one step close to things running smoothly.
Who knew an update came out on 11-11-2022 I didn’t even know…

Hello @lorentedford

Welcome to the forums I hope you are having a great time!

In regards to the quest and the glitch that shows the video I would suggest the following quick fixes:

-Restart the quest. (Delete and re take).
-Relog your game completely (close steam and re open).
-Run a files verification by steam. Steam Support :: Verify Integrity of Game Files.

To troubleshoot the usage of the CPU you can try some of the tips here: Troubleshooting Frame Rate and Performance Issues - Support | Amazon Games. In case that you did not find a solution for this situation please create a web ticket in order to better ivestigate it.

Best wishes Adventurer!

Hello Achieveme I don’t think you actually watched the video if you did you would see that some of the advice you gave isn’t necessarily applicable to our situation in this post. First off changing settings to low didn’t solve the cpu usages. I reached out to support but was ignored immediately telling me that they solved a login issue that was unrelated to my support ticket then they closed the ticket instead of reading the ticket or watching the video. This is why I am as a last result reaching out publicly in your forums section for assistance. I did to file verification but since I do it regularly i had nothing missing and all files were verified.

I will say that heating isn’t the issue since we updated the cpu’s cooler recently and applied new thermal paste as well… Please remember the cpu specs and the video when commenting on a solution to this issue… Thank you for your time!

1 Like

Well it updating the bios didn’t help…

Hello @lorentedford

Hope you are doing great and I apologize if the troubleshooting that I offered did not helped in this situation. I would like to note that I did saw the video where your quest was reseting every time you try to complete the ritual.
This glitch was affecting other players and reseting the quest helped in most of the cases. Please confirm on this post if the quest is still bugged in order to scalate it.
Regardig the CPU usage the troubleshooting above is the the most recent to offer. I suggest to be aware of the forums in case there will be new information related to this topic and visit your computer tech for more deeper look into the CPU usage.

Best wishes adventurer!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.