My Armor is missing upon post patch login

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Razputtin
  • What server/world did you experience your issue on:Hy-Brasil
  • Describe the issue you are experiencing: All my equipped armor is missing
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: no armor
  • (if a bug) Were you able to recover from the issue:no
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced: logged into game for first time since patch today, my character has no armor equipped which was there last night when I logged. I checked all of my storage locations and nothing. Tried logging in and out multiple times and nothing
2 Likes

This has also happened to me. i had a full set of harvester gear on.
Character: Hermione.01
Server: Valhalla

I have the same exact problem.

  • What is your character name in New World: Epikrato

  • What server/world did you experience your issue on. Asphodel

  • Describe the issue you are experiencing: All my equipped armor is missing

  • Is this a bug or an exploit: Bug

  • (if a bug) How did the issue effect your gameplay: no armor

  • (if a bug) Were you able to recover from the issue:no

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

  • What are the steps to reproduce the issue as you experienced: logged into game for first time since patch today, my character has no armor equipped which was there last night when I logged. I checked all of my storage locations and nothing. Tried logging in and out multiple times and nothing

I also lost all my equipped armor. It was harvester armor just like hermyonee.

  • What is your character name in New World: Vondoo
  • What server/world did you experience your issue on: Midian
  • Describe the issue you are experiencing: All my equipped armor is missing
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: no armor
  • (if a bug) Were you able to recover from the issue: no
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced: logged in after downloading the latest patch and all my armor was missing

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.