My game doesnt even load now?

My game was working just fine last night. then this morning, i go to play and i can’t get past the front NewWorld screen. A game crash updater loads after some time, but i cannot open that at all. and the only option i have is to close new world through task manager. I have verified the game files multiple times, Un downloaded and reinstalled the game and still the same issue. then i again, verified the game files and no errors. nothing to fix.

What am i to do?

Hello @lXMissAthenaXl,

Hope you are doing well.

I apologize for the trouble caused to you, for which you can follow this troubleshooting related with the AGS Files that are linked within New World:

  1. Windows + R type in %APPDATA%
  2. Go to Local and Roaming (Both files will include an AGS file) and open them.
  3. Rename the AGS sub-folder ‘‘New World’’ to something different like ‘’_New World"
  4. This will refresh the cache files within New World.

If this troubleshooting doesn’t work you can also follow the troubleshooting for frame rate and performance issues using this link:

Also you may refer:

Hope this helps. :magic_wand:

1 Like

so, I tried renaming the files, and now the game makes a noise on the same page? but I still don’t go past the “new world” page. I don’t even get the AGS animation. I’m just stuck on the loading screen. I’ve contacted AGS and they said that they will email me… pending results. Thank you.

1 Like

Assuming you have an nvidia graphics card, NW has a contentious relationship with nvidia drivers, and this issue seems to keep popping up every few driver revisions.

Since there was a new driver push a couple days ago that might be the issue.

  1. download DDU and remove the old drivers

  2. download and install a previous version of the drivers and skip this version

Hope this helps!

it was indeed a driver issue. i cannot say just how grateful i am… Thank you so so much!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.