My PC shutdowns constantly when I try to play the game since today (GPU crash)

Hi. I just wanted to mention that I have a GPU crash constantly since today’s update. I remember that I had some problems before in the preview aswell (same GPU). But capping the FPS was enough to not having this problem. Yesterday I played the game without a single crash. Today however it was completely different. I’ve spent the entire day trying to play the game for more than 10 minutes straight. First I thought it was because of overheat, but after downgrading my GPU a 10% (a 10%!!!), putting my graphics on low and my GPU fans at the max, I had another crash at 50ºC. And then, I managed to get to Fisherman’s Bend for the campaign, and my PC shutted down. Automatically, and every time I tried to log in again, instantly. My graphic card is an RX Vega x64 Sapphire. I hope this information helps in any way, and I also hope that I can play this game eventually, because, I really like it.

1 Like

as I stated in the post, after a long day of queues not working properly, when i finally made it into the game, this happened to me instantly

Hello @FlintlockDavid! Hope you’re doing fine, just to check with you some basic information, which version of windows are you running and is it up to date? (currently only windows 10 is compatible), are the card drivers updated?, Has it given you any error message or slows down before it crashed? Let me know!

Yes, I have the windows updated, the drivers aswell, and there’s no error message. It simply happens like that

Update: Today’s patch greatly improved my condition: Now instead of getting my computer shut down whenever I’m near to Fisherman’s Bend, my game just crashes whenever I try to fish, recovering control from my computer afterwards. Here’s a little video where it can be seen:
https://medal.tv/clips/3ZDrs7PWOFjqo/d1337gg1fOVv

I don’t know what you are doing but whatever you did it seems to work, thanks and keep it up!

Awesome glad to hear that there is a bit of improvement, the developer team is working super hard on the issues that are showing up, let me know if something else comes up or there is any changes on that error, Safe travels adventurer!

1 Like

sadly, today It happened me again, twice. Well at least it’s not like before, but still a downgrade


yeah idk when i enter into the game this happens instantly

No troll mate, but this is classic GPU/Video overheat issue with the way this SCREEN is presenting.

Try to remove your graphics card and remove any dust. Give it a little love.
If your GPU is built in, then you will likely hear the FANS ramping up rapidly if you have a airflow/dust situation that is impacting performance.

Play in WINDOW MODE
Play in the SMALLEST WINDOW SETTINGS
Reduce setting to LOW
Drop FPS to 30

You are basically dumbing down your PC until you find the point at which you get stability. If you still crash like this after dropping everything look at adding some additional cooling (Fan/Remove Panel) to increase airflow.

It is unlikely you are getting to this crash point without the FANS or some other audible change in the computers normal behaviour. Game like this push cards to their limits, and the minimum spec for this game is very high.

REPLACE your file with this one.

It is preconfigured to go to minimum settings.
C:\Users\xxx\AppData\Roaming\AGS\New World\savedata

I changed a lot of stuffs to try if it’s about overheat or not. Changed the quality to all low, fps cap to 60, raised the potency of my fans to maximum and underclocked my GPU to 10% and I have these crashes at 50ºC, It doesn’t seem to be heat related. Anyway, I always try to give to my PC the love it deserves. Also have in consideration that There’s days where I don’t have any problem and days where I have a shit load of ones

Thanks for the info, I would like to investigate further, could you please send a pastebin of your logs to me via PM. It will be the most recent file under C:/Users//AppData/local/AGS\LogBackups

sure thing