New Side-Quest "The First Thing I Remember" in Restless Shore is bugged for me

  • What is your character name in New World: ZeakOne
  • What server/world did you experience your issue on: Ursa
  • Describe the issue you are experiencing:

So, first i talked to the NPC Santiago Salazar to get his quest. I was doing all tasks and then it was needed to talk to him again. But he complete disappeared. So i tried relogging and all possible things but nothing happened. So i thought, i could try to abandon the quest and trigger it again. But now it shows me only the questmarker on the map and the NPC dont appear at all anymore not even to getting the quest again.

4 Likes

Same issue, haven’t found a fix either. Just want to echo that its more than just you.

1 Like

Yea same here. I took the quest and when i had to talk to him and he disappeared. Abandoned the quest and now the marker is on the map but the guy is not there

Same problem. Took first step of quest, killed a Lost, got a note, went back and Santiago is AWOL and quest marker is nowhere on map.

I found him by luck, he’s at NW of the Restless Shore settlement. (like 100m)
For some reason his marker is not green, but you can talk to him and continue the quest.

4 Likes

its a the NORTH of the settlement, not NW

3 Likes

Yay, i also found him now in the North of Restless Shore, but it seems that abandoning the quest didnt reset the NPC to his original place in the far west of RS so that i cant trigger the quest again. And talking to him now is just saying that i didnt found nothing about his past. To make a long story short, abandoning the quest is resetting your quest-item but not resetting the NPC.

Pls fix :slight_smile:

6 Likes

yay, but this is just helpful for people which didnt abandoned the quest…if u abandoned the quest then u cant trigger the quest again…

Thanks for the screenshot @Pannry
@Blacksmith.Andre that looks like NW to me :slightly_smiling_face:

Still not fixed after today’s update. Had to search here to find out where he was.

At least he is findable and the quest continues!

Not if u abandoned the questline and try to restarting it, thats the main issue what we talking about.

Same Bug here… So many bugged Quests after 5 months, is this early access?

I abandoned day one, still not fixed with today’s patch. If they’re not going to let me continue this quest, I wish there was some way to remove the quest marker, it’s my only uncompleted quest…

So… this will be the month that Mr. Santiago will be back on square one right?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.