New World Complete and instant Crash

any one else have an issue where while playing and running youtube on a second monitor, sometimes when one video finished and the next starts New World completely crashes, like no warning just straight to desktop total crash ? its not every time but maybe about 10-15% of the time

Hello njclaver,

Thank you so much for reporting this behavior within New World using a second screen.

For this issue I want to know if this is only happening with New World, if this is the case can you please check this troubleshooting:

  1. Windows + R type in %APPDATA%
  2. Go to Local and Roaming (Both files will include an AGS file) and open them.
  3. Rename the AGS sub-folder ‘‘New World’’ to something different like ‘’_New World"
  4. This will refresh the cache files within New World.
  5. Apply a Steam Integrity Check files:
  1. Restart your PC.

If the problem keeps happening can you please also verify if your GPU’s drivers are up to date:

Please if the issue keeps happening let me know to help you as soon as possible and see you back in Aeternum with both screens without any crashing or performance issue. (づ ◕‿◕ )づ

Screenshot 2022-04-14 5.56.31 AMpastedImage (3)Screenshot 2022-04-14 5.56.31 AM

Never had that happen.

Aside from the usual NW troubleshooting.

Update Video Driver
Ensure you’re BIOS is up to date - they’re always doing stability updates. I had some crashes that were a problem with W10 and CPU Microcode and there was a BIOS update that completely fixed it.

If you have a GPU on your CPU make sure that driver is up to date as well. You can disable it in bios too but before you go that route try disabling GPU acceleration in the browser and see if that helps.