New World Launch Issue

Hello all,

For the first time ever I am having issues with the game not loading up.
First happened last night and I have done nothing new that would change or alter any files but I pressed ‘play’ and it loads the in-between screen before the game loads. (See image below) I only notice the issue because the symbol doesn’t rotate and it does not progress me further on this screen.

I am slightly confused by this.

I have verified the game files, twice, and reinstalled the game today to see if there was any other missing files and this has not solved the issue and thus making the game unplayable.

I would love some advise from others or developers how I can fix this issue.

Thanks

Jeff

Hello @Jeffw0mbat ,

Greetings! :handshake:

I am sorry to know that your game is not loading up.

Thanks for sharing the screenshot of the issue and the troubleshooting that you have tried.

Do you get any error after a few mins of this screen ? If yes kindly help me with the code/message that pops up.

Apart from this I recommend you to try the steps below and see if it works-

  1. Easy Anti cheat Repair-
    repair or reinstall EAC, instructions are here: Easy Anti-Cheat
  2. Disable temporarily firewall .
  3. Disable Ipv6.

I hope this helps!

Thank you in advance for trying the steps. :evergreen_tree: :sunflower:

Hello @Helianthus ,

Thanks for the quick response. Very much appreciated.

I updated my GPU drivers as this is something I have not considered and it worked! Game is working and I am back in.
Good to know for future use.

Thanks

Jeff

1 Like

Great to know that it works now and you found a solution! :slight_smile:

Take care! :wave:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.