New World Won't start

Everytime i try to start the game it flickers black 1 time and stops starting without error message.
The crashuploaderlog everytime shows the following error:
[2021-07-21T21:51:10] [11160:11224:20210721,215110.255:ERROR main_win.inl:27] Initializing windows game crash uploader logging
[2021-07-21T21:51:10] [11160:11224:20210721,215110.257:ERROR GameCrashUploader.cpp:47] GetUserStreamSources
I tried everything to make it work but nothing works.
Does somebody know a fix for it?

i spent 8hrs on these issues yesterday and even resorted to amazon game support. nothing worked for me. sent a bug report to anticheat as that is what we saw start/stop in services

today again 4hrs testing different stuff. no fix. just took a refund until this is discussed and a known fix is posted.

Hi @Ismahaan, I can see that you’re getting some issues to get access to the game. I’d like to recommend you to take a look at the following Topic where you can find this issue explained in detail and some possible solutions.

I tried disabling ipv6 right now but it did not help.
I also do not get the error message “product information not found”.
I actually get no error message at all

Before setting out on an adventure please make sure that your system meets the following minimum system specs:

  • CPU - Intel® Core™ i5-2400K, AMD CPU w/ 4 physical cores @ 3Ghz
  • GPU - NVIDIA® GTX 670 2GB, AMD Radeon™ R9 280
  • Mem - 8GB RAM
  • Disk - 7200 HDD
  • OS - Windows® 10 64-bit, DirectX 12
  • Storage - 50 GB available space

For the optimal experience surviving the Corruption of Aeternum:

  • CPU - Intel® Core™ i7-2600K, AMD Ryzen™ 5 1400
  • GPU - NVIDIA® GTX 970, AMD Radeon™ R9 390X
  • Mem - 16GB RAM
  • Disk - SSD
  • OS - Windows®10 64-bit, DirectX 12
  • Storage - 50 GB available space
  • If your system is still running into issues launching the game and your system meets the minimum requirements, be sure to verify the integrity of the game client files using the steps here: Steam File Integrity Check.
  • Confirm that you are using the most recent GPU drivers for your Graphics Card (AMD ) (NVIDIA ).
  • Confirm that you have the most recent updates installed for Windows 10.
  • Check that you have the most recent BIOS updates installed (important for newer AMD Chipsets and Motherboards).
  • Try a clean boot of Windows: How to perform a clean boot in Windows . (This will disable all non-essential programs from starting and test if there’s any background programs causing a conflict with the game.)

It works now. Apparently windows update did not update my windows correctly.
I used this link to download the newest version and it fixed the problem for me:
https://www.microsoft.com/en-us/software-download/windows10
Thanks for helping. :smiley: