"No Product information found" Error message at launch

I tried every fix that is posted on this forum with no success. After each supposed “fix” I have restarted my PC to make sure all settings and resets stick. I’m still getting the error message at launch. I’ve been at this since 13:00 EST and have gotten nowhere.

Windows is up to date
Drivers are up to date
Nvidia drives are up to date

There’s nothing left for me to do at this point.

Hello & welcome to the forum community!

We are sorry to hear about this launch error you are experiencing.

If you have tried every troubleshooting steps on the forums including:

  1. From the Start/Windows Menu, select Settings.
  2. Select Network and Internet.
  3. In the Status section, under Change your network settings, select Change adapter options.
  4. When the Network Connections window opens, right-click your network connection.
  5. Select Properties.6. Scroll to Internet Protocol version 6.
  6. Uncheck the Internet Protocol Version 6 (TCP/IPv6) box.
  7. Select OK to save your changes for the selected network adapter.
  8. Try launching the game again. A PC restart may be necessary.

Please use this link so you can escalate this issue.

https://www.amazongames.com/en-us/support

I hope this helps!

Already tried this.
Flushed my DNS too.
Reverted my graphics driver since it updated today and that was the only new variable between last night when I logged off and today. Still not working.
I keep restarting my PC and verifying the steam files.

We appreciate all your efforts on this situation.

Can you try disabling any antivirus software temporarily? (any other than windows antiviruses)

I have disabled all firewalls and anti-virus software. I’m still having the same issue. Something to note, I am able to run the PTR and play in the test server. Not sure if this gives any clues

Thank you! Can you use a VPN connection to see if it allows you to access the Aeternum?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.