No product information found..?

To report a player or company for Code of Conduct violations, please do so here

  • What is your character name in New World: N/A
  • What server/world did you experience your issue on: N/A
  • Describe the issue you are experiencing: Can’t even play. Game launches but doesn’t verify my game’s Product code or something.
  • Is this a bug or an exploit: Honestly have no idea, I guess bug?
  • (if a bug) How did the issue effect your gameplay: Couldn’t even get in the game
  • (if a bug) Were you able to recover from the issue: No.
  • (if a bug) Please include a screenshot or video of the issue that you have experienced: Imgur: The magic of the Internet (I’m not sure what you want me to do about screenshots I don’t want to waste time…)
  • What are the steps to reproduce the issue as you experienced: Just starting the game and waiting 10 seconds after downloading. I’ve verified files and turned off IPV6 I have tried everything I could think of.
  • When did this happen? (Date and Relative time; please include your timezone) TODAY. Around 4-5 pm. EST.

Hello @Ecco, Welcome to the forums!

I am sorry to hear that you’re having issues launching the game, I know you mentioned that you already attempted to turn off the IPv6 but just to confirm please follow the steps listed on this post:

If you’re still having issues please contact us so we can escalate the problem, here is the contact information:

Hope this helps!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.