North Edengrove shrine is broken

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: DaAlmyteJR

  • What server/world did you experience your issue on: Caer Sidi

  • Describe the issue you are experiencing: You are unable to teleport to the Gatherer’s Road teleport shrine in north Edengrove

  • Is this a bug or an exploit: Bug

  • (if a bug) How did the issue effect your gameplay: More walking

  • (if a bug) Were you able to recover from the issue: No.

  • (if a bug) Please include a screenshot or video of the issue that you have experienced: https://i.imgur.com/p3t6RWQ.png

  • What are the steps to reproduce the issue as you experienced:

I was going to use that shrine and also have the same issue. The south shrine in Edengrove works just like in your photo. The north one doesn’t. :frowning:

same still no fiz for this?
i walked up there when i did not have 2

Currently having the same problem. Very odd.

I’m having a similar issue. I can’t fast travel anywhere. It seems as if all of my previously visited shrines and settlements have been forgotten.

They have moved some shrines. Same for BW, one closest to the fort. I just ran up to them and they work fine for me now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.