Out post rush sign up not working

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Ryokin
  • What server/world did you experience your issue on: Valhalla
  • Describe the issue you are experiencing: the que for outpost rush does not work
  • Is this a bug or an exploit: bug
  • (if a bug) How did the issue effect your gameplay: trying to sign up for outpost rush
  • (if a bug) Were you able to recover from the issue: no does not work
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced:

Hi, Outpost Rush requires to have a level 60 character. Can you confirm that you can’t sign up although you have a level 60 character? In your screenshot, I can see that it says that you have a pending group invite, have you tried to cancel that group invite and sign up again?

Also there is a minimum of players required for the game mode to launch. It needs 32 players in the queue. When you sign up, a banner will appear where you will see the number of players currently in the queue. If it’s below 30, the game won’t launch.

Can you check and let me know if that still doesn’t work?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.