Patch after patch and performance still s:)cks

Greetings Adventures, please bump this topic to the sky if you have similar problems… :slight_smile:

Dear Team,
The optimization of the game is terrible, and even worse after the last patches. In my opinion, this is more important than void gauntlent or other “features”.
My CPU usage is 90% when i cut trees. In other situations, it is always 100%. There are regular FPS drops and desyncs/lags in Outpost Rush.

My comp spec:

  • CPU - i5-9400F,
  • GPU - RTX 2060,
  • RAM - 16GB DDR4
  • DISC - SSD

I guess that should be enough for an MMO… On 1920x1080 and all settings to low.

Additional:

  • In PvP, players at longer distances (but accessible to the musket) disappear in random situations. It looks like you have decreased the rendering range of players (and not just players).
  • In Outpost Rush (and not only there) the rendering of grass or objects like boxes is often delayed or starts when approaching them (because of performance i guess).
  • “Max FPS” setting doesn’t work correctly. If I set 60, I have 75 cap. If I set 30, I have 37.5 (which is half my monitor’s refresh rate - half of 75 Hz, maybe there is problem?).

@Luxendra, @Tosch, @Lane and others from the team:
I created this post because you are not responding to other similar ones:

The game is two months old and still unplayable in pvp, especially for ranged players. Please answer if there is anything done in this case and when we can expect corrections.

Screens with CPU usage are available in linked topics.

There is screen with “Max FPS”.

Greetings,
Ence :wink:

1 Like

I hope others will reply too and Amazon stops doin more bugs with too fast updates and finally do something with performance and clear the existing bugs…

I have a little bit better specs, RTX3060 and i5-10400, 32gb ram, SSD and still having the same issues you wrote…

I play on low settings, everything at low and capped at 30 fps, and my CPU usage is 100% with 93 °C all the time… Only thing i can do is decrease my CPU max usage to 99% at windows power plan, thats fix the usage around 70% and have normal temperature (if i do nothing)… but i cant do pvp or even pve with more ppl around with this throttling because its block the TurboBoost technology, so my max clock is 2.4 Ghz instead of 4.4 Ghz so the game laggs like hell…

Basically i cant use my laptop full capacity, because game will kill my hardwares like this…
And i cant play the game normally if i want to save my laptop…

All this started for me after a patch, dont remember the exact patch but point is something wrong and have to be fixed/optimized!

Before that it was great for me, i know my specs are not a power machine, but i played on all low settings with 60 fps cap and the game was smooth even at Outpost Rush midfight, and now i cant kill 3 pve mob w/o laggs…

I have every driver updated, same as windows updates.

Please fix this!

1 Like

Thanks for response!

Does the “max fps” function work properly for you and is it really capped to 60 fps?

Yea thats works for me and capped at 60/30… Should be something hardware/sofsware specific problem at you…
Like as i see you have i5 cpu too, maybe this cpu problem appears only at i5 type or something…
But im not an IT man so dont know…

Since patch 1.1, the New World graphics has a few issues for me…
This image should explain it a bit…


Trees in the close mid-range are blocky…
Trees in the distance are as you would expect, but the ‘close’ mid-range trees are terrible…

I have the settings all on low, for a reason. So that my computer doesn’t overheat.
Before the patch, everything was running perfectly on this setting. The graphics were good, the temperature of my computer was good.

But now it is terrible… all since patch 1.1…

I have done everything right, the settings on low, the fps set to 60. But in reality, my fps is higher, around 70 or above.
The temperature of my GPU, CPU, and motherboard is running warmer than it used to before the 1.1 patch.

What has AGS done to the graphics of this game in the 1.1 patch that is causing these issues?

Please fix them… I am afraid to play the game.

2 Likes

Hello, I could solve the temperature problem by deactivating the turbo bost of the bios. I had it in automatic and obviously it is activated with this game and it raised my temperature, when deactivating it it is running at 70c °. But the Fps keep falling at times, before I was 60 all the time and now they vary between 40 and 58.
Try the bios that I told you to see if the temperature is solved. Hope AGS fixes these bugs.

Using google translator.

1 Like

i just noticed an increase in cpu usage in town, was already high , but now is more even high, sometimes i reach 80/100% with an 8700k, i never maxed my cpu in any game but new world.

Hello, with today’s patch is it solved? or could you fix it another way?

Today’s patch made it worse. Processor jumps from 46% usage to 98% when entering a semi-deserted settlement. My game already crashed once.

I don’t see any changes.

Met the same issue. i5 7300hq. Constant 100% cpu usage. Turbo boost is being automaticly turned off by my pc only in this game and freq is stuck at 2.5 instead of 3.2
Did had semi-stable 50fps in 768p and with few tweaks in lods-loading system (additional nvidia settings)
Now it is unplayable for me.

Also look at software “Process Lasso”. You can do some tweaks, such as lower cpu cores usage particular for New World process. And be carefull with this issue, because if it really runs your cpu on 100, it can easily burn part of your cpu lifetime.

It is not 100% loaded, because 100% = turboboost on. It is not being turned on, because my pc will not let burn himself.

Can someone from the team comment?? Is the i5-9400f too weak to play New World?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.