Permanently dead.. Character can't respawn or unstuck?


My friends can resurrect on my game account, but I can’t resurrect on my own computer

@Sersei It happened again today. Server was really laggy. She died by mobs spazzing out. On respawn got in a long loading screen. And then back to being dead with no respawning possibility.

Same problem since today, yesterday I enter to the eternal pool arena, now i can’t respawn by my self, I just can be revived by another player.
Username: Moscardone
World: Kvenland (ES/EN)

Same problem.
Yesterday I died and I can’t revive
Username: Pabeu
Serwer: Montes Serrorum (EU Central)

Same problem for me, can’t revive i’m just stuck dead in a place…
Username: Hydrogen94
Server: Vainola (EU Central)

Still got bugged even if i close steam for like 1 hour…how is possible that a bug like this is still in game after 2 patch? i can expect stuff like this from a free to play not from a game that i paid 40 Eur…

1 Like

I tried to get killed with PVP activated by another faction memeber and I can’t die completelly… thats crazy, by the way noone can resurect me… im full dead right now, and i cant play the game in any way, plz fix this bug…

1 Like

When i died (not full dead just inmobilized) on PVP i restarted the game, and I was alive qhen i enter on the server on the place I were inmobilized.
Now I rolled into a magmatic place and I cant respawn on any place, cant be revived at this place, no way at this point… PLZ FIX THIS BUG, GAME IS FULL OVER TO ME NOW.

2 Likes

Just died ,tried to respawn to camp,waited 10 minutes in loading screen, I was not respawned and the respawn UI was gone

. :frowning: :frowning: .

EDIT: restarting the client fixed the issue for me .

Same problem for my friend: imobilized dead underwatter and we can revive him, he is not pvp on so that another player can kill him
Username: PequideGoias
Server: Aratta (SA)

I’m also having this bug in the same SA server (Aratta), nickname:Hordrux. Please, fix this game-breaking bug

Still bugged

Username: Gedaii
Server: Alatyr (SA-East)

xxxxxxxxxxxxxxxxxxxxxxx

bump FIX THIS.

  • What is your character name in New World: Lunar Suiren
  • What server/world did you experience your issue on: Emain Albach
  • Describe the issue you are experiencing: After dying in the water I got stuck floating dead, unable to respawn.
  • Is this a bug or an exploit: bug
  • (if a bug) How did the issue effect your gameplay: Can’t play with my lvl 60 character.
  • (if a bug) Were you able to recover from the issue: No, I need help.
  • (if a bug) Please include a screenshot or video of the issue that you have experienced: Ok
  • What are the steps to reproduce the issue as you experienced: Just dying in the water in the Ebone Scale sea after killing Bear Elite Boss.

Yo Sigo con el mismo error pero para mi desgracia caí en una zona donde ningún otro jugador puede entrar, la única respuesta que me dan es que espere al próximo parche o que vuelva a crear mi personaje desde cero. Es notablemente que es un error en la programación del juego.
Sigo esperando una respuesta de su parte. D30549990 .
Pésimo servicio de atención al cliente, como programador sé que esto se puede solucionar fácilmente con un teleport, una restauración del personaje, que me maten directamente para poder liberar, o simplemente ponerme en una zona donde las personas me puedan ver y levantarme ya que por el mismo error del juego, por problemas de colisión de su propio juego, estoy en una zona inaccesible para los demás.

“We’re working on a fix and are confident it’ll be ready next week.”

I’m also stuck has anyone been unstuck if so how many days did it take because I am now on day 3 of not being able to play the game while I try and contact support trying to figure out my situation for hours and hours on end.


PLEASE HELP!

Ya see the problem with posting things like this on Public forums

I really like your PC
How well does the Ryzen 7 3700x pair with a 2060 Super? Never heard of that company for video cards though, KFA2 or Galaxy?
Jealous of the fact you have 32Gb of ram though, bit more than me.
Apparently your system has been running for 423.5 hours, imagine if you had this problem at 420, that’d be perfect.

Anyways, something something privacy and logs on the internet.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.