Pinned quests journal disappears in Corrupted events and does not come back

  • What is your character name in New World:


  • What server/world did you experience your issue on:


  • Describe the issue you are experiencing:

When a corrupted event pops up in the area I am in, my pinned quests journal disappears. I mean the list that is displayed on the right side of the screen. This happens when I am leaving the corrupted event area and the top right corner displays a note (not exact words) “If you leave the area you will loose contribution rewards”. Sometimes this popup note stays and never leaves even I leave the area completely. Quest log display does not return either never.
I’ve tried the unstuck feature, no help.

  • Is this a bug or an exploit:


  • (if a bug) How did the issue effect your gameplay:

Well, you don’t see the quests you have pinned. One has to constantly check the map for where your quests are. And you need to relog to fix this. And not to speak that with the current queue times, RELOG IS NOT AN OPTION! I’ve entered a corrupted event area TWO times now only and the bug occured on both times.

  • (if a bug) Were you able to recover from the issue:

Only by relogging.

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

No screenshot yet. I’ll post one if it occurs again.

  • What are the steps to reproduce the issue as you experienced:

Hide the UI completely then unhide, no help
Unstuck, no help

Does the game have a reset UI command like World of Warcraft does (/reloadui)? Relogging in this case is NOT an option.


On third time, the Pinned quest list didn’t disappear but this “Abandoning Event” note is stuck and never leaves. See the screenshot.

I am nowhere close to the event location and it’s been over 30 minutes since I was there.

1 Like

Tried to change screen resolution, does not reset the UI.

FIX THIS ASAP PLEASE! tired of getting this bug and having to relog and get stuck in queues to solve it! ridiculous!


if u walk in and out of corrupted area it will disapear. Som times u ned to do it sevral times. just walk in and out. fast fix and dont need to relog

Yes, but if your Pinned quest logs has disappered the above fix will not bring it back. If quest list is missing you need to relog to get it back.


is there any fix ?

This is still happening. I have played 2 hours this morning and EVERY time I enter a corrupted event area (porta, monolith, …) the quest log disappears and NEVER comes back.

Please fix. You can’t expect us to relog all the time because of this. These corrupted events are EVERYWHERE.

1 Like

Has happened today for 5 times now. Can you please fix this. Re-logging is not an option with these high queue times.

Give us a option to reload the full UI like in WoW with /reloadui.

1 Like

Same bug. Happens every day, very annoying!

1 Like

This needs to be fixed ASAP! With the queue times you can’t expect us to relog because of this bug. There’s no way to reset the UI to brting up the quest list without relogging.

1 Like

this is a daily occurrence. once you leave it long enough you lose compass and then the questlog on screen. im hoping they are already aware and some maintenance is coming soon.

1 Like

Same here. Never realised how much I used the pinned quests until it disappeared with no easy way of getting it back. Needs to be fixed asap.

Same here, pinned quest are gone after I was at the expedition (that is also laggy af)

Too bad, did not see any fix relating to this in the latest upcoming 1.0.1 patch. o.O

But let’s hope it’s coming. At least the queues are better now so relogging is not such a pain anymore, but still. As I am not the only one who has this issue it should be looked into by devs.

1 Like

This also happens and is related to this problem my man: Compass issues - disappearing resources marks - MAJOR BUG - #18 by hellseesyou

Its the same issue, OR very similar

In general the UI needs some QoL love. <3

Yeah I’m getting sick of googling a fix while I’m relogging, stuck in queue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.